Showing results for 
Show  only  | Search instead for 
Did you mean: 

menu options not showing on LCD screen under manual settings




 I have a Rebel T1i and am hoping to reset the camera to factory but when I try toggle to Manual Settings or any of the Creative Modes, when I press menu button, I don't see any of the menu options.  The only time I see the menu options on the LCD screen is when I toggle to the video and then I press menu, I see the options.  Unfortunately, under the video settings, I don't have the third screwdriver logo option for factory reset.  Does anyone know why I can't attain the menu options when I select the manual settings?  The LCD screen is working but it won't take me to the menu option settings at all.  I have removed the battery from the camera for two days and tried to factory reset that way but it didn't work.


Please help if you have any advise on why my camera is behavig this way.


thanks in advance


Product Expert
Product Expert

Hi tnpandcc!


Thanks for checking in with us.


It sounds like you've already tried much of what we would suggest, but you could also try to remove the memory card and any other accessories. Inspect the camera to see if any button seems stuck or out of place. If so, try to nudge it back into position.


If problems persist, I suggest that you email us to learn more about the service options availabe to you:


" I have removed the battery from the camera for two days and tried to factory reset that way but it didn't work."


You are right. That won't reset the T1i.  If I remember correctly the T1i still has the small keep alive button battery. It must be removed also to do a hard reset.  If it doesn't have that small button battery (its in the battery compartment where the main battery is) two days isn't even close to how long you need to leave the main battery out.  Several months is closer.


I never had a T1i but a family member did but check to see if it has the small button battery.

EOS 1DX and 1D Mk IV and less lenses then before!


You can always adjust the screen geometric settings manually using geometry menu items TelltheBell.



 Thanks for your suggestion.  How do I get to the menu settings where I can reset to factory settings by doing the geometric setting?   When I toggle to Manual , the screen shows it's on M but when I press menu, nothing happens.  All the menu options do not display.  But when it's toggled to video, and I press menu, I do see all the menu options ( unfortunately, the third screwdriver logo does not show up --only two .  The third screwdriver is where the factory reset option is given under the creative modes ( M, Av, etc).


Any other suggestions?


Thanks in advance.