cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wifi issue between R7 and Google Pixels

Nico95
Contributor

Hello,

Since the last update, I can't use the Canon connect app with my Google Pixel 6. Bluetooth connection is OK but I can't use wifi features.

I tried to reset connection, I tried a brand new Pixel 8 and I have the same issue.

I tried with an old Xiaomi and it works.

I think that Google and their uncompromising security policy has broken the Canon wifi connexion.

If I try to connect manually, my phone says "password mismatch".

I'm sure I'm not the only one 😞

Canon, could you please make something for us please ?

Thank you!

40 REPLIES 40

comp615
Apprentice

I'm also experiencing this with a Canon r8. I'm on the pixel 7 with December security update and it no longer works where it did before. I tried with the November update and all fine.

Bluetooth connection is still fine, the issue occurs whenever you try to import images (or anything that triggers the "swap" to WiFi). The phone will attempt to make the direct connection to the camera, but will give a generic sytem-level connection failed message (then the canon app will also say failed to connect).

Given the relatively low help I've seen provided on this forum besides linking to the manual, I think we'll need to find another way to escalate this issue and it will likely involve filing a bug on the Android support system too so that Canon and Google can fix this. I'll browse around more, but wanted to say thanks for posting since all the VIP support I've seen here has been pretty gaslighty. Need to find a way to reach someone actually technical at Canon

Thank you!

Yes I was thinking that I could reach a Canon support engineer here but no.

I contact the Canon support and you may do it too to make it a more important problem for them.

I'm pretty sure Canon was using a WiFi security issue to connect and Google fixed it. So I try Canon support first.

I'll let you know.

Waddizzle: as comp615, this is a generic WiFi error and we don't have any information on what is going wrong. I'm not paid to debug this issue so I'm going to let the Canon support do that.

See my post on the previous page on how to fix it. I reckon (well my son reckons) its a recent Android security bug. You need to remove using a password when the camera sets up its wifi network. (If you switch your camera off it creates a new network and you start again. Bums!)

nibbo
Contributor

Hi,

Just bought the R7 and going mad while trying to connect to my Pixel 7 via wifi (as above). Got my son to connect to his iphone no problems.After 1.5 hours of head scratching we've come to the conclusion there is a recent Android bug. After some redditing we came across this solution.

If I manually configure the R7 to host a WiFi network without a password then I can connect no problem. Select

  • connect via WiFi

  • switch network

  • Camera Access Point Mode

  • Manual connection

  • OK

  • Auto

  • Encryption setting - None

  • Auto

Phone and camera should then be able to WiFi connect. Problem is when you disconnect the app doesn't remember any of this connection so attempts to connect again with AES enabled so you have to go through this process each time.

So...that's how to get round it until the Android bug is fixed

Thank you for this tip. It can be helpful if you have no other choice but I want to keep my WiFi private.

I don't think it's an android bug. If it was a bug, the January update would have fixed it.

I've only just hit this which was the whole purpose of buying the R7. This is typical as I bought the camera WiFi pack for the 7D some years ago and I never got it to work.  You did say it started after the December Android update in Dec? I've updated the firmware in the R7 too to no avail  Would be nice to know the exact problem.

Appreciate the tip! Manually creating access point without security works (temporarily)

Canon R7 with Pixel 6 also checking in with same issue as most other people.

ajweinert71
Apprentice

Just wanted to add my two cents worth to this post.  I have exactly the same issue with the R7 and Pixel 7 Pro.  I have tried everything to get the WIFI connection working with no success (apart from the temporary fix with AES disabled).  I have tried the connection with two Samsung devices with Android 13 and one Samsung device with Android 14 and each time the WIFI connects straight away, so the problem does seem to be isolated to the Pixel devices and not Android itself.

Doktordok
Apprentice

Same problem here. Everything used to work fine.

No changes to R7 whatsoever. Pixel 6a will only connect on Bluetooth but won't establish WiFi connection any more. 

Have reset camera settings and uninstalled and reinstalled app. Still broken. Definitely seems like a phone update has broken the protocol between the phone and camera.

Total pain as this is the only way I use to get photos off my camera.

 

Error messages below for completeness 

Same problem is in other forums. Needs a change in the app to handle increased security on pixel phones.

"Perform the necessary operations on the camera to stop using the camera's Wi-Fi function as well."

"Could not connect to Wi-Fi. Please wait a little while and try again."

shadowsports
Legend
Legend

I really feel for all those who have reported an issue.  Its escapes me how I am not having any issues connecting to Bluetooth only, Wi-Fi only or both with a Pixel 6 or 8.  I've done nothing special or disabled anything. Works for me 100% of the time and I can't explain why.    

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements