cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Update firmware 70D problem

Rahim99
Apprentice

hello
I got problem with my 70D current software 1.1.1

Its Probably a software problem :

this button below on the camera don’t work :

gallery , info , delete , Set button 

when i tried to make update from my memory card i can’t continue because “Set button” dont work

i tried to install Eos utility 2 ; it detected my camera i can use the software but when i try to update firmware it’s says clic ‘ Set button’ on your camera to confirm firmware update

i trying to use Eos utility 3 ; its says camera can not recognized ( i have try vers 3.10 and 3.15 last ) same msg err

 

can someone guide me to update my firmware 

 

thanks for your answer 

1 REPLY 1

NatalyaP
Product Expert
Product Expert

Greetings Rahim99,

The EOS 70D is compatible with the EOS Utility 2 software but it will not function with EOS Utility 3. Please check that the lock switch on the camera is not enabled. This switch is located towards the bottom portion of the back of the camera.

After the firmware has been copied over to the memory card, we can then navigate through the camera's menu to the firmware portion and proceed to update the camera's firmware. Touch screen functionality may not be available when going through the firmware update to where we would need to use the physcial dials of the camera. Rotating the dial clockwise and counter-clockwise will allow for us to select the options display in the camera's menu. The SET button would function to then allow us to select the action for the camera to begin the firmware update.

In case you continue to experience issues, then you may reach out to our phone support team where they can assist you step by step in real time with updating the firmware on the camera. They can be reached at 1-800-652-2666, Monday through Friday between 9:00 am to 9:00 pm ET and Saturday between 9:00 am to 7:00 pm ET.

Avatar
click here to view the gallery
Announcements