Showing results for 
Show  only  | Search instead for 
Did you mean: 

Time Delay in Shutter Releasing.


I have a Canon EOS Rebel T3i.  A have a problem with the shutter not releasing when I push the shutter button or when I use a cable release.  I'll press the shutter and it may not take a picture for a 10 count or more.  Sometimes it will work correctly sometimes it takes 3 or 4 button pushes before it takes the picture.  The focus points light up and I've reset the camera.  The worst part is it seems to be getting worse.

(It makes for real frustrating bird photos).  Any ideas?


Product Expert
Product Expert

Hi JustJC,

Thanks for checking in with us.

One thing you could try is to clean the contact points on your lens and your camera. If you have not done this yet you can do so by turning the camera off, removing the lens, then brushing those metal points on both the lens and the camera body with a lens cloth.

Now, take a few more test shots, keeping in mind the following shooting tips. There's a good chance you already know these principles, but I thought I'd run through them as a sort of quick review.

To obtain sharp, accurate images, the shutter button should be pressed halfway to allow the camera to meter and focus. When focus has been achieved, the camera may beep or show a light indicator next to the viewfinder. At that point, the shutter should be depressed fully to take the picture.

Keep in mind that the autofocus might not work well in the following situations:

* Subjects with extremely low contrast to the surroundings

* Subjects mixing close and far objects, like shooting a scene through a chain-link fence

* Subjects with extremely bright objects at the center of the composition

* Subjects that are moving quickly

* Subjects in low-light environments

To shoot these subjects, first aim the camera at an object at a similar distance, lock the focus and recompose the image with the desired subject, or use the manual focus.

You may also wish to try a different lens on your camera. If you don't have other lenses, then you might try a display model that is found at your local camera or electronics store. Sometimes focus issues can be due to the camera body and not the lens.

I tried cleaning the contacts and it "almost" worked for one pix (only a 1 or 2 count before the shutter tripped).  Subsequent photos toke a 5 count or more.  I actually shot a LCD flat screen TV (lots of light and only one focal plane).  I got a beep confirming focus and the appropriate focus points lit in the viewfinder and it still took a 5 count or more for the camera to take the photo.  Switched to Manual exposure on the camera and still the delay.  Switched the lens to manual focus, the lens beeped, the focus LEDs lit and it took a 7 count before the shutter tripped.  It looks like I'll have to look at maintenance.


Are you using the flash?


Hopefully it is just not attaining focus. If it doesn't it won't fire. A small bird against a bright sky can present a problem for AF.

Try this after you do a full reset and clear all custom settings at the same time.

Set P mode. Set ISO 200. Set WB to average. One shot and best to use just the center focus point.

Now on a nice sunny day go out side and take some random shots. Make sure there are vertical lines in some of them. Like trees a fence or buildings, etc.  If it works, it works and nothing is wrong. If it doesn't and still presents the same issue, it needs service.

EOS 1DX and 1D Mk IV and less lenses then before!