Showing results for 
Show  only  | Search instead for 
Did you mean: 

T4i Not recognised by laptop


Please help,


My laptop is not recognising my camera, I keep on getting a messing in the device manager saying


Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.


I am using windows 10, I have been battling with this problem for a while and tonight I have done a clean re-install of windows 10 and the problem is still there.



Have you tried a different USB cable? Has it ever worked with the cable you're using now? Have you tried a different USB port?

Philadelphia, Pennsylvania USA

I have tried a few different cables, i am using the cable which came with the camera, tried different ports and nothing seems to be working.  Camera is detected but only enough to give me that error message, it's almost as if my laptop detects something being attached to the USB but it doesn't know what it is and what to do with it.  I have had this camera for a few years, purchased it now, never tried this as I didn't have a need for it, I am getting into astrophotography and this ability to connect to my laptop would be really helpful.


Super frustrated at this point.

Camera issue cofirmed, attempted to connect a different camera and it works. I wonder if this could be repaired??

I do not see communication option on my t4i is there a hidden menu maybe??

click here to view the gallery