cancel
Showing results for 
Search instead for 
Did you mean: 

Sudden autofocus problem on 5D Mark III

sdhweb
Contributor

Hello, I have a nearly two years old 5D Mark III with only 7800 images taken. The camera has been working well and I've been happy until now.

 

Yesterday I experienced that autofocus would not work on an easy target. I thought 'what the heck is going on?'... After that incident I keep having this problem. Sometimes autofocus seems to work and sometimes it seems to do nothing at all. The focus confirmation light and the AF status indicator is just flashing.

 

I use the AF-ON button for focus and the IS is leaping to action but the autofocus doesn't seem to be doing anything. I experience this on contrasty subjects in full daylight. And suddenly it may be working again but it seems very unstable. I haven't done any changes to the settings before this started to happen.

 

It seems to be worse when I change back and forth between focusing on something close and something far away. If I manually adjust the lense very much out of focus it seems to have a very hard time to get back on track. Mostly it fails. If I then help it quite a bit and manually adjust the lense more in focus it suddenly works again.

 

I've always had the setting 'Lense drive when AF impossible' set to OFF and I've never had these problems before. Changing this setting to ON seems to 'help' a little, it at least changes the behaviour of the autofocus. With this enabled in seems to at least be trying (and more often succeed) instead of just doing nothing. Keep in mind that I'm talking about good and easy autofocusing conditions here, not low light situations.

 

Conciderations:

1. I have tried two different lenses with the same result (EF 70-200 F4L IS USM and the EF 100 F2,8L IS macro)

2. I have cleaned the lense contacts on both the body and the lense.

3. I've upgraded from firmware 1.2.3 to 1.3.3 and reset the camera to factory settings.

4. I've changed focus back to the shutter button

 

None of the above actions have made any difference to the situation. I've had this camera for nearly two years and something has definitely happened. The camera is very well treated and have no visible damages.

 

Any advice on this one?

 

 

13 REPLIES 13

SR71Norm
Apprentice

I am having this very same issue.  I have always kept my camera secure and clean.  Apparently from the reply threads below this is an item that must be repaired by canon.  Does anyone know if this is an issue that is covered by their warrany program or not?  Is there perhaps a recall on this?  Thank-you.

You read the whole thread and understood what was the problem to my camera? After the repair it has worked flawlessly. I had to pay myself but the repair was not more than 180 USD which isn't too bad.

Yes I did read all the threads. I understand that they told you that your camera's AF-sensor had somehow gotten shifted out of it's calibrated position and that you sent it in for repair and that they re-calibrated it and now it is all fixed. I also have taken very good care with my Canon 5d3 and cannot understand how this problem could have happened. I had noticed this issue for a while now, but since it was so intermittent I had not investigated it. To me it appears to be a manufacturer failure, but I have not found any recall on it yet. I guess I will have to "bite the bullet" and send it in for repair on my own dime. Pretty sure I did NOT cause this. Thanks for your info on this issue and I hope I have as good an outcome as you have.

No problem. I was in the same position as you. They said that the sensor had been shifted out of position and that this only can be caused by a physical impact. Like you I have no idea how this might have happened. I tried to argue with the service technician who told me that it was quite common for them to hear that 'nothing has happened' to my camera.

I just had to accept the fact that I do not have full control over the camera 100% of the time. For example when I keep it in a bag I can leave this bag unattended by me. There is a small possibility that the kids might have bumped into it and don't dare to tell me <shrugh>

Announcements
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM