cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel t6 WIFI will not connect to phone

aganchegui
Apprentice

My camera used to be able to connect via wifi to my phone. I hadn't tried in a while and now it doesn't work. My phone is not even seeing the wifi as an option in my available networks. I have an Iphone 13 promax and a rebel t6. 

2 REPLIES 2

NatalyaP
Product Expert
Product Expert

Greetings aganchegui,

Let's go ahead and reset the wireless settings on the camera and attempt to make a new connection to your iPhone:

  1. Turn the camera on and press the “Menu” button. Navigate to the third tools tab which is labeled in yellow and has a symbol of a wrench.

    2. Highlight and select “Wi-Fi function” on this menu screen by pressing SET on the camera.

    3. Press the “DISP” button on the camera.

    4. Select “Clear Wi-Fi settings” and then select “OK” when it’s displayed on the camera’s screen.

    5. If the Wi-Fi/NFC option shows “Disable”, then select “Enable” to enable the wireless feature on the camera. You may need to provide a new nickname for the camera.

    6. Then highlight and select “Wi-Fi function” on the menu screen by pressing SET on the camera.

    7. Select the top center icon for connecting to the smartphone.

    8. Select “Easy connection” and select “OK” on the bottom right of the screen.

    9. The camera LCD screen will display a password which is labeled “Encryption key”.

    10. Go to the Wi-Fi network screen on your phone, select the camera to connect to and then enter in the new password when prompted.

    11. After connecting to the camera's Wi-Fi on the phone please navigate and open the Canon Camera Connect app. Please wait up to 30 seconds until you see a window pop up which will state “New camera found”. It will display the camera within this window. Tap on your camera model to connect to it.

    12. On the back of your camera you will see your phone appear on the LCD screen. Press “OK” on the bottom right. This will finalize the handshake between the two devices.

I would also recommend disabling or turning off any VPN feature or app on the iPhone prior to connecting the phone to the EOS Rebel T6 via Wi-Fi. If possible, please test the connection on a different mobile device. This may help to determine if there is something on your iPhone that is causing an issue.

I tried that and still nothing. I even tried a different IPhone and an Android

Avatar
click here to view the gallery
Announcements