Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel t3 has fully Charged battery, but won't turn on....any suggestions?

I have tried two fully charged batteries, but my rebel t3 won't turn is about 4 years has not been dropped or damaged....and I used it about 3-4 weeks ago with no problem. Any suggestions?

I did read in the manual that there are two different batteries......I have no idea where the second one is located or even how big it is.....


My rebel t3i wouldnt turn on! Thougt it was the battery so I bought a new one. Didn't work. Read some post and thought maybe there was a loose connetcion where the battery goes or the memory card. If either one of those isn't secure it won't work. Not the case. It was my memory card, I has switched it from my Nikon to my Canon and it wouldn't work. I put the memory card into my Mac, deleted everything off of it, put the card back in and the camera works fine. Years of using cameras and I guess I am an idiot....but you don't switch memory cards back and forth unless you format them first. MY BAD.



Happy to have finally solved this problem and at no cost..except now I have a back up battery..which isn't a bad thing.



View solution in original post



The second battery is internal to camera and not user replaceable. It is charged by the main battery.


Are sure that the two batteries are fully charged? A defective charger could indicate charge but not be charging.



John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic


Similar problem with my T2i, haven't used the camera for a while, charged the battery and menu display won't come on. When attempting to take a picture the flash will work as will the shutter, so it seems the battery is charged. Just no display.


The camera has two micro-switches to verify that the (a) memory card door and (b) battery compartment door are fully closed. There are some tabs on the doors which push on the respective door switches.


Check to make sure your doors have a good fit and that the tabs aren't damamged in any way are able to close completey.


If the switches are not engaged then the camera will not power up.


Tim Campbell
5D III, 5D IV, 60Da

Thanks for the suggestion. That is not the problem with the T2i. I wonder if it is a faulty - old battery or bad memory card.

I had a similar problem with my T3i, this morning.  Camera would not power up.  After reading your comments about checking the bay doors, I reseeded my SD card and battery and crossed my fingers.  


To my surprise, the camera came back to life.  It was really scarry, to think of replacing my baby and the money required to do so. 

Canon rebel t3i I have two batteries and worked fine 5 days ago. SD card has been used for several years. Took out battery, took out SD card. Replaced battery and camera powered on. Placed SD card back in and camera would not power on. Placed anothr SD card in and camera works. 


I was able to place the first SD card in my pc and back up the 1500 or so pictures. 


Cannon website says this camera is not supported any longer 


I just saw your post. I am having the same problem with my T3i. Just started a week ago.

Mine just died about a week ago. It will not turn on or do anything. The last time it work the back screen turned on and then just died. I noticed the battery seems a little fat and I think it sorted the board, or blew a capacitor. This blows.

I finally got a new battery that worked. Took one back to Best Buy and got another one at Staples. Some of those cheap ones from China are not worth the money. Give the new one plenty of time to charge before trying to use it. Good luck.

click here to view the gallery