Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 wifi connection problems


I have a 5D Mark IV, 1DX Mark III, and R5.

Both the 5D and 1DX connect fine to my wifi network.

The R5 will connect to my iPhone 11 Pro Max hotspot fine. Works every time.

But I have spent hours trying to connect to my wifi so I don't have to use hotspot data with no joy.

I have tried the wizard connection, manual connection, I have tried DHCP, I have reserved an address and manually entered it, I have used WPS, with IPv6 enabled and disabled, etc. - nothing works.

We have multiple iPhones, an android phone, multiple tablets, laptops, computers, audio amplifiers, wireless speakers, printers (including a Canon), and other devices connected to the wifi with no problem.

The R5 sees both 5G and 2.4G networks in it's scan. It will allow me to enter select the network and enter a password. Then it connects to the network because I can use an IP scanner to see the IP and MAC address as online. If using WPS the router will also report the device is successfully connected.

But when I try to use image.Canon I always - 100% of the time, get an error:

"err 125 check the network settings"

According to Canon documentation that is simply a failure to connect to a network.

If I use the exact same procedure (scan for networks, select network, enter password, connect, etc.) but instead of my wifi network use my iPhone hotspot it works perfect.

Does anyone have a clue why my R5 would refuse to work with my wifi network when both my 5D and 1DX work fine? Why it will connect to my iPhone and work with, but not the wifi network?

My router is a Linksys EA9500 extended range. Again I have tried both the 2.4GHz and the 5.0GHz connections. I know I am entering the correct password.

What would prevent this connection from working when the iPhone hotspot works perfectly?

By working perfectly with iPhone hotspot I mean it:

  • Connects every time
  • Stays connected
  • If I take a photo it is automatically uploaded to image.Canon
  • If I take a photo it is automatically forwarded to cloud storage
  • if I take a photo it is automatically downloaded to my computer via the client software
  • If I take a photo it is automatically sent to the iOS app

Just as it should, except the R5 refuses to work with my wifi even though I can verify it can communicate with router by either using WPS and the router saying it successfully added the device or by connecting another way and using IP scanner to verify manually assigned IP and mac address are in fact connected to router.

But for some reason the R5 doesn't think it has a network connection and gives me the err 125 every time.

Anyone else having this problem? I see a lot who the camera gets hung up scanning for networks but not the specific problem I am having. Surely someone else has a Linksys router and is trying to connect the R5. Is it just this brand of wifi router? Some configuration setting? But everything from a decade old wireless Klipsch speakers and Yamaha amplifiers to older and newer iPads, iPhones, android phones, laptops, computers etc. will all connect just fine. Why not the R5?

Technically it will connect, it just doesn't know it is connected and won't work with image.Canon




Do you have the EOS Utility installed?

Start by confirming the camera is connected to your router.  Log into the admin portal and check attached or connected devices..  Not sure what Lynksys calls it in their GUI.  The IP and MAC should match what you see in your IP Scanner.      

Then try following these steps after logging into the portal. | Camera connection procedure

Hopefully this will shed some light on your connectivity issue.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8 ~CarePaks Are Worth It


Thank you for the thought but as outlined above the problem is not connecting to the wifi. The R5 does that and I already confirmed IP and MAC. The problem is the error code that it throws 100% of the time when following the instructions if connected to the wifi. It gets to a point in the process and throws an error message related to network settings.

But if I connect to an iPhone or iPad hotspot it works perfectly. It just won't work with the wifi.

EOS Utility works fine. The R5 will connect to the wifi network and pair with the computer just fine.

But for whatever reason the R5 throws the err 125 after connecting to the wifi network and then trying to go through the setup with image.Canon.

So to summarize:

  • R5 "sees" both the 2.4 and 5 Ghz wifi networks
  • R5 will connect to the wifi networks using either manual selection and password input or WPS
  • I can confirm R5 is connected using IP scanner which shows IP and MAC address of R5 connected
  • R5 will pair with EOS Utility
  • When paired with EOS Utility all functions work including live view shooting etc.
  • But if trying to complete the setup process for image.Canon the R5 throws err 125 when connected to wifi
  • However if I connect to iPhone or iPad hotspot and then follow instructions for image.Canon it completes the process
  • When R5 is connected to iPhone or iPad and will transfer photos to image.Canon as well as cloud storage and download to the Canon downloader client on the PC.

But I have spent hours trying to get it to connect via wifi rather than mobile hotspot and 100% of the time it throws the err 125 which says to check network settings. I have removed and added back network connections, etc.

The reason it matters is mobile carriers throttle internet speed after a specific quantity of bandwidth each month and it becomes too slow to be usable for transferring images or videos. It doesn't take that many raw photos and very little video to exceed most data caps that trigger throttling.

So I need to be able to connect to and utilize wifi at home, office, or on location without relying on cell phone mobile hotspot unless absolutely necessary in some location where wifi is not an option.

It makes no sense to me that image.Canon works fine with hotspot but won't work with a network the camera will connect to and can use to pair with computer etc.

I guess I will try uninstalling EOS Utility, restarting computer, reinstalling. I have not done that yet because I have the latest version and it works with my 1DX Mark III, 1DX Mark II, 5D Mark IV. I don't really see how EOS Utility impacts image.Canon but I do see on forums that some people have issues connecting to the network with the R5 unless they uninstall and reinstall EOS Utility. Continuous scanning isn't my issue nor is the ability to actually connect to the wifi network.

But it might be worth a try to uninstall, reinstall, and pair with EOS Utility before I try using image.Canon. I will update this thread if it works.

Meanwhile if anyone else has had this specific issue with their R5 please let me know how you resolved it.


Just as an FYI...

I uninstalled:

  • Canon Utilities EOS Network Setting Tool
  • Canon Utilities EOS Utility 2
  • Canon Utilities EOS Utility 3
  • Canon Utilities Web Services Registration

I downloaded and reinstalled latest version of software above.

After reinstall I connected to EOS Utilities and confirmed it worked including Live View remote shooting.

Then I tried image.Canon and had the same issue as before - err 125

All of this using wifi network that utilizes the Linksys router.

However, when I switch networks to the iPhone hotspot it works fine and transfers photos to image.Canon as it should.

So no change after uninstalling and reinstalling Canon Utilities. The R5 still refuses to use the same wifi network that it recognizes and will connect to with Canon EOS Utilities when using image.Canon. So I am still forced to use the iPhone or iPad hotspot to transfer photos.


IMHO it's a glitch with the 5GHz WiFi.  I have the R5 ~3 months and when I upgraded to it I had an old Verizon WiFi router that was only 2.4 GHz and I was able to use the Wi-Fi.  Last week I upgraded to the Verizon Quantum Gateway router (I know, still not the current one) which has both 2.4 and 5.0.  Since I expected the R5 to be able to handle both and since I thought, perhaps incorrectly, that the 5GHz band would be faster, I tried to reconfigure the R5 for the 5GHz Wi-Fi and had essential the same experience as described above.  When I switched back to the 2.4 GHz band, it's now working.


Further notes on this glitch. The file transfer via WiFi works only when the R5 is in the room with the main WiFi router AND I turn the camera on then; waking from sleep doesn't count.  When the R5 is turned on near the router, the R5 will use WiFi to upload all images taken since the last upload.  If I do so when in the room with the router, but then move to another part of the house (where I know there is a strong WiFi signal as I have not one but two Verizon range extenders), the file transfer stops and I have to go back to square one.

If someone from Canon tech support is listening, please fix this.

click here to view the press release