Showing results for 
Search instead for 
Did you mean: 

My Canon Rebel T4i will not take pictures.

Occasional Contributor

My camera is not taking pictures.  This is the first time this has happened and I have had it for a few months.  I downloaded the firmware update but don't know what to do next.


Forum Elite

"I downloaded the firmware update ..."


And you attempted to install it?  The install failed?  Or was interupted by something no matter how minor?


"... but don't know what to do next."


If, yes, to those you will need to send the camera to canon service.

EOS 1DX and 1D Mk IV and several lenses!

Occasional Contributor

I don't know how to install that on the camera.  It installed fine onto the computer, but I don't know how to transfer the new firmware to the camera.

The SD card must be formated by the camera you want to use.

You simply put the firmware on that SD card from your computer and put that into the camera.  The SD must have nothing else on it but the firmware update and it must be in the root folder.  Which it will be if you just copy it to the SD card.

Turn on the camera and follow the instructions to install a new firmware or keep the old one.


EOS 1DX and 1D Mk IV and several lenses!

Occasional Contributor

You may have to dumb it down for me a little more.  My computer doesn't have a place for an SD card.  Can I transfer it to the card while it is in the camera.  My camera has two empty file folders that are always in it, even after formatting.  DCIM and MISC.  I have formatted the card, but can't figure out how to transfer the file to the card, or even which file.  It initially downloaded the ksd290a_installer, and I can't move that to the card - I have tried.  Then on my computer desktop there are 4 things it downloaded:  Digital Photo Professional, EOS Utility, Picture Style Editor and ImageBrowse something.  They only one I tried to move to the camera was EOS Utility and it won't allow me to put it on there.


I really do appreciate your help, but I just need more general instructions.


You can get a card reader.  They are not expensive.  Walmart has them.  You can not use the camera to do this.  You just copy the firmware update directly to the SD card.  Do not put it into any folder.  Just drop it on the card.

You did not download the firmware if those files are what you have. The firmware is for Windoze machines.   You didn't say which you had.  Read below.............


EOS Rebel T4i

Firmware Version 1.0.4 incorporates the following fixes:

1. Fixes the following phenomena which may occur when the camera is used in combination with certain lens models equipped with a stepping motor.
Affected lenses: EF-S 18-135mm f/3.5-5.6 IS STM / EF-S 18-55mm f/3.5-5.6 IS STM.
        1. The camera may freeze in rare instances if you try to shoot with a lens cap attached or meter a subject in low contrast in Live View (or Movie) shooting.
        2. Fine focus adjustment may not be possible in Remote Live View on the EOS Utility software.
2. Fixes a phenomenon in which some SD card products are not recognized by the camera.
3. Corrects some misspellings displayed on the menu screen.

Firmware Version 1.0.4 is for cameras with firmware Version 1.0.1 or earlier. If the camera’s firmware is already Version 1.0.4, it is not necessary to update the firmware.

When updating the firmware of your camera, please first review the instructions thoroughly before you download the firmware.

EOS 1DX and 1D Mk IV and several lenses!

Occasional Contributor
OK, I will get a card reader and then try again. There was someplace that it said it had detected Windows 7 before it downloaded.