cancel
Showing results for 
Search instead for 
Did you mean: 

Lens busy

RedskinRobbie
Contributor

I purchased a reconditioned T4i almost 2 years ago and love it. My only complaint is the noise form the autofocus during video, but that wasn't why I bought it; I wanted to take good pictures of the dogs, and our exploits with them.

 

A couple of months ago at a dog show, when I tried to use my camera with the EFS 18-55mm lens, every time I tried to take a shot, I got a message that it was “Busy”, and wouldn’t take a shot. After fiddling with it for a few minutes, I swapped out the lens, for my EFS 55-250 and it worked fine. I swapped them back and got the same issue. If memory serves me right it said the lens was busy, but by that time I needed to get busy so I put the 55-20 lens on it and got busy, {felt like a sniper taking pics but it worked}. Once we got home I took the 18-55 out, put it on the body, and it worked fine. The only thing I could figure was it had something to do with the cold, it was really cold.

 

Has anyone else experienced this? I read the forums listed as “Busy”, but they either didn’t work after swapping lenses, or it seemed to be a product of attempting to take pics too quickly, for the autofocus for the setting.

 

On another note, I have a EOS Rebel 35mm film camera, from when they first came out, and it has an EF 35-80mm lens, which will fit my T4i, if I’d had it I would have tried it, but will it work on my T4i, and will the AF work as well.

 

If anyone knows, Thanks

2 REPLIES 2

jrhoffman75
Legend

The 35-80 will work on your digital Rebel. It is old tecnology for focusing - it uses a slow micro-motor - but if will give you a little more reach than your 18-55.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic

Thanks,

  Wish I'd had it with me.

Announcements