cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LCD screen has gone blank

RLaCount
Contributor

I received the Rebel t4i for Christmas. It's been working great until today. The lcd screen no longer shows any information. If I press any of the setting buttons (ISO, etc), nothing shows up. It worked fine this past weekend.

52 REPLIES 52

Hi Scott,

 

Your second solution actually did the magic for me. i have been struggling with blank scree on my EOS Rebel 4Ti and looking for a solution until i read your post. Immediately i removed the eyecup, i could see my settings on the display. Thanks for the valuable contribution.

Hello Scott,

 

I have the same issue of display gone blank in LCD Screen.. I tried cleaning all the sensors...  But when I move the video option, the display working.. but on any of the photo option. Can you please help in resolving this.

 

THanks for your help in advance

 

Best wishes


Raghunathan


@ScottyP wrote:

Will it work under any circumstances? 

Will it work (show moving pictures) in live view shooting movies? 

If you press "MENU" do  you see anything? 

If you hit the "PLAY" button can  you view photos you have taken?


 

The only way my T3i LCD continuously works is in Video mode. It will light up when you turn off the camera and also when you press the shutter button (currently stuck in delay mode). Pressing any other button has no effect on the display.

jju
Apprentice

Help!  Did you ever find the solution to this problem?  My lCD screen went blank this morning, it was working fine yesterday.  I called the support center and they had no answers for me.

I am sorry, but I ended up sending mine back to get fixed. I never was told what was wrong to begin with. Luckily, it was still under warranty., Again, I'm sorry.

ScottyP
Authority
Good! Glad you didn't have to go through the ordeal with the shop.
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?

I report that without the info above I could have looked forever to find the tiny unmarked square between the eyecup and the hot shoe. And who would ever figure that it turns off the screen? Mine is an SL1. The design is like an adventure game.

Thank you for describing exactly where to look for the unmarked square! Your description stood out to me just as I was about to give up, and then I took a second look where you described, and sure enough there was the little square (to my surprise!), and there was a piece of dust stuck to it that was causing the screen to go black. I was about to assume it was broken before reading your words; You saved the day- Thank you very very much!!

wefranco
Apprentice

I had the same problem yesterday and the ScottyP suggestion solved it immediatily. Just an additional point, the eyecup padding was just slid 1/16. Thank you for help!

 

"(2.) Also make sure that the rubber "eyecup" padding has not slid up 1/4 inch and covered the "display off sensor" that turns the display off when you put your face up to the camera." 

CharleneSeaman
Apprentice

I've been traveling in Spain with my new Canon T5 and after three weeks of taking photos.  Today the screen, too, has decided to go blank.  Suggestions?

Avatar
click here to view the press release
Announcements