Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to Download Photos from an EOS Rebel XS to a Computer


I cannot get the pictures from my Rebel XS to upload to my new PC laptop. So I tried to upload to my old desktop. I can't get the pictures uploaded there either. Any and all help is appreciated. Thanks!



Hello. Were you able to transfer images to your old laptop before this time?

We recommend that you use a card reader to upload images from the camera card to a computer.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Yes, a year ago I uploaded pictures the desktop. Now they won't go.

Was that the same operating system you have now?

What software did you use to download images?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic



To have a better understanding of your issue, please let everyone know the operating system on your computer.

If this is a time-sensitive matter, please check out your other support options here.


It's a Dell Inspiron running Windows 11


Be more giving of information, please. Can you tell us HOW you are attempting to move pictures from camera to computer? What exactly is/is not happening? 

Have you tried the memory card in a card reader, rather than connecting camera to computer?

What operating system did the old computer have? 

Absolutely, these items of information are critical.

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris


It's a 64 bit operating system, x64-based processor


I connected with a cord from camera to laptop. I don't have a card reader. My old desktop, where I originally downloaded the software from a CD Rom was a windows 8 (I believe)


Two things:

Try a new cable, they go bad or it can be one of the charging only abominations.

On the XS, I believe there is a PC/PTP setting. Put it to PTP.