cancel
Showing results for 
Search instead for 
Did you mean: 

HDMI out stopped working 90D

rickmorton
Occasional Contributor

I have anew 90D I'm using for live streaming along with my 80D. I've been using USB for video out and it's been fine. I thought I'd try using HDMI since it's supposed to be better quality. Yesterday I connected a new HDMI mini to HDMI to my 90D and my CamLink and coonected to my iMac. I opened FaceTime and it worked fine.

This morning I opened my live streaming software, eCamm, and while it shows CamLink as an available camera source, I get a black screen. Re-starter computer, camera, etc. Still nothing, To eliminate a cable  issue I plugged in the 80D and it works fine in FaceTime and eCamm. ??? Yesterday the 90D worked. Today it doesn't. I'm baffled. Any thoughts?

I'm in CLEAN HDMI mode, 29.97 FHD which is same as the 80D.

2 REPLIES 2

Waddizzle
VIP

Are you connected to the HDMI and USB at the same time.  If so, don't do that. Make only one connection.

------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

rickmorton
Occasional Contributor

UPDATE.  After psoting I turned off/on camera. Closed eCamm, re-opened. Unplugged HDMI. Not sure of any sequence, but the camera came up. ?? I hate when that happens.

I have a couple of USB ssd drives attached, but no USB camera. Maybe I'll try disabling the facetime camera in eCamm. Maybe that will help. Thanks.