Showing results for 
Search instead for 
Did you mean: 

First visit here, trying to load a ds6041 into new computer with Windows8.


Newbie here. Hope I'm asking this on the right place.

I've been trying to get my DS6041 to work in Win8, not having any luck. I have tried downloading the disc for both 10d and a 300d with no results. When I open the zoombrowser and try to connect the camera I get popup that says "Camera not found"


This EOS has worked fine with WinXP since I got it (way back when) . Is there a new driver I have to upload or something?

By the way... the label on my camera says DS6041 , DC8.1V, No. 1760515654... is this a 10D or a 300D?

Thanks, Joe


I'm sorry but I don't believe in  paying for the codec pack. Microsoft does provide the codec for x64bit windows to read RAW camera format and it does support Canon camera. Canon is one of the biggest camera manufacture in the world and you think MS not supporting their cameras would be a joke.

Here is the list of supported Canon cameras and you can Goolge MS camera codec pack for the download link.


EOS 50D Digital, EOS 60D, EOS 300D, EOS 350D, EOS 400D, EOS 450D, EOS 500D, EOS 550D, EOS 600D, EOS 1000D, EOS 5D, EOS 5D Mark II, EOS 5D Mark III, EOS 7D Digital, EOS D30, EOS D60, EOS Digital Rebel, EOS Kiss Digital, EOS Kiss Digital N, EOS Kiss Digital X, EOS Kiss F, EOS Kiss X2, EOS Kiss X3, EOS Kiss X4, EOS Kiss X50, EOS M, EOS Rebel T1i, EOS Rebel T2i, EOS Rebel T3, EOS Rebel T3i, EOS Rebel XS, EOS Rebel XSi, EOS-1D, EOS-1D X, EOS-1D Mark II, EOS-1D Mark II N, EOS-1D Mark III, EOS-1D Mark IV, EOS-1Ds, EOS-1Ds Mark II, EOS-1Ds Mark III, PowerShot G1 X, PowerShot G2, PowerShot G3, PowerShot G5, PowerShot G6, PowerShot G9, PowerShot G10, PowerShot G11, PowerShot G12, PowerShot G15, PowerShot Pro1, PowerShot S90, PowerShot S95, PowerShot S100, PowerShot S110, PowerShot SX1 IS


File name:
Date Published:



File size:


13.3 MB

Weekend Travelers Blog | Eastern Sierra Fall Color Guide

I agree on not paying but unfortunately the MS and Canon codec's don't work with raw files created by my T4i under Win 7 64 bit OS, the purchased ones on the other hand do work.  It was the only workable solution I found.  If those work for you, good for you.


PS - I did try the ones listed for Windows 7 64 prior to purchasing the 3d party ones, they didn't work

Another user having the same problem,


I changed the communication to P2P but the camera isn't showing up in My Computer where I would normally open a flash drive. Do you have any idea of what I could try next? I just want to get these old pictures off my grandfather's camera. Thanks in advance

I never plug the camera directly into the computer.  I pull the card out of the camera and using that adapter plug it into the camera and it works for me.

I "USED TO" do that, but several years ago I bent a pin in my camera because I was taking the card in and out so much. Cost me WAY too much to get it fixed. I just leave the card in the EOS and use the USB cord

Nope, never did find a "real" resolution. Win8 just doesnt seem to want to recognise my EOS when I try to open it with the Canon program. The program actually opens when I plug the EOS into the computer and turn it on, but after the program opens it says "No camera was found".


So I just close the Canon program and use File Explorer to open the camera and download all my pix from there. They open up in Windows Photo Explorer,  and I have created files in "My Documents" to transfer the pix there.


Oh well ...


Hey guys, DS6041 is the part number for the body of the original Digital Rebel (or EOS 300D as it was known in Europe) that came out back in 2003! Since camera and computer technology has changed so much since then, the camera might not be compatible with Windows 8. If one of our Community members doesn't have experience with this particular camera and Windows 8, we'll get one of our Product Experts to weigh in on the matter!


Hey Joe - I have the same model camera and also running Win 8 Pro 64 bit. Did you ever find a working soluton?

I've set the camera's communication mode to PTP, but Win 8 doesn't recognize it when attached directly via USB.


I had also downloaded what I think is the correct Canon driver, even though I'm told it shouldn't be necessary, but still no luck. Please let me know if you found a fix and I will update this thread as well if I find one.

06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM