Showing results for 
Show  only  | Search instead for 
Did you mean: 

External flash control


Hi all.

I have somewhat of a puzzling question. I have a Canon 60D with a Neewer / Godox 860 Speedlite. When on the hotshoe I go into menu for flash control and set all the settings like power, mode and all on the camera. However, when the flash is actually off camera. I go to the same menu and it says It cant find the flash. Still works fine as it triggers.


I was doing a product shoot today and has the speedlite on the ground lighting the product from below. I had to change power settings a couple of times and had to get down there to set it on the flash manually.


Is this just how it is, or am I missing some knowledge.


Please assist

thank you



How are you triggering it? optical or radio or off-camera cord?

radio, I use radio to trigger

I guess the radio trigger does not communicate with the camera properly.

I also thought so, so I tried another set. Still no luck.

Have you talked to the radio trigger people?

You are on a Canon board asking for help with two pieces of non-Canon Equipment. We have enough trouble keeping all the Canon stuff straight! 8^)

Personnally, I think it is a Canon issue. two different type of triggers and the neewer reads correct when on camera so It can not be faulty. But thx. I get the idea.

I got the exact opposite impression. SInce the flash works without the trigger it seems that the trigger is not talking to the camera correctly.

Most, if not all, manufacturers will not guarantee that their products will work fully with third-party devices. Folks like Neweer, Yuongno, etc. try to reverse engineer the appropriate signals to send to their device, but since thay don't have access to actual Canon code they aren't always successful.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
click here to view the press release