Showing results for 
Search instead for 
Did you mean: 

Error message "Cannot playback image" on Canon 7D using an SDHC card in a CF adapter


Just purchased a new 32GB 45MB/s Sandisk SDHC card and popped it in my CF card adapter for my Canon 7D camera. Started off doing a few trial shots and worked fine. Tried another day and worked fine at the time (or so I thought) Images all visible on the screen on replay.


I then went on a trip to London last night and was happily shooting and looking at the images regularly to check what they were loooking like and everything was initially fine. Half way trhougb the shooting I noiced that I suddenly had an error message appear "Cannot playback image". Just tried downloading onto my PC through Lightroom and nothing to be found. Says the images have not been recorded or maybe corrupted.


Does anyone know

1) How this could have happened please?

2) If there is anyway that I can retrieve the files with this message or are they all likely to be either not there or corrupted if they are there?


( The second test shoot appeared satisfactory at the time and all the images were visible fine but on loading 50% were corrupted)


Any help / advice warmly welcomed please


+ Any free Sandisc recovery programs that might help?




Is it possible that the card is too fast for your adapter? Or too large; have you used the adapter with a 32GB SD card before? I'd suggest sticking to real CF cards. My 7Ds have never had any sort of problem with those.

Philadelphia, Pennsylvania USA


You can try here.


Do not use the card until you try the recovery.  In the future stick with CF cards.

EOS 1DX and 1D Mk IV and several lenses!