cancel
Showing results for 
Search instead for 
Did you mean: 

EOS T6- Focusing issues (not related to MF/AF button)

aroryborealis
Occasional Contributor

Hi Everyone-  I have a t6 which is is not locking onto things in AF when I use my viewfinder.  it will zoom in and out past focus and then just not take the shot.  It will focus and take the shot in live view mode so I know the camera can focus, lock and take a shot.  I have no issues taking a pic in MF.  This happens when the camera is in any mode including auto mode, and lighting is not a factor (indoor, outdoor, bright or low light its still an issue).  I reset the camera settings already.  I am concerned that given that it focuses OK in live mode, could this mean that the mirror our AF points are dirty?   

15 REPLIES 15

Waddizzle
VIP
It might. Let a professional look at it. Contact Canon Support.
------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

Tim
Respected Contributor

hello aroryborealis, 

We are sorry to hear the issues with your product persist.  We recommend sending it into Canon for evaluation.  You may fill out an online repair request form at the following link to setup your repair using our online service.

https://www.usa.canon.com/internet/portal/us/home/support/service-repair

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

aroryborealis
Occasional Contributor

How much does sending to Canon for evaluation cost?

John_
Respected Contributor

Go on the Canon website, register your camera first then use the support phone number to call them for help as well as an estimate for any repairs.

Ronni44
New Contributor

@aroryborealis wrote:

Hi Everyone-  I have a t6 which is is not locking onto things in AF when I use my viewfinder.  it will zoom in and out past focus and then just not take the shot.  It will focus and take the shot in live view mode so I know the camera can focus, lock and take a shot.  I have no issues taking a pic in MF.  This happens when the camera is in any mode including auto mode, and lighting is not a factor (indoor, outdoor, bright or low light its still an issue). showbox reset the camera settings already.  I am concerned that given that it focuses OK in live mode, could this mean that the mirror our AF points are dirty?   


Yes the point is dirty.

Ray-uk
Reputable Contributor

There are various things that could cause this, dirty mirror or focus sensor are probably the least likely. Do NOT attempt to clean them yourself because you are likely to cause more damage, seek the advice of a professional repair shop.

aroryborealis
Occasional Contributor

thanks, what other issues would you think it is?  

Waddizzle
VIP
How much? Use the link provided Tim.
------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."

aroryborealis
Occasional Contributor

Thanks everyone-  I did get my hands on another lens and suddenly the issue was gone so now I am thinking its the lens.  its the cheapo kit 18-55mm lens so not worth returning.  Does anyone know of this issue in a lens or if theres an easy fix?  I did clean the contacts to no avail.  Thanks again.