cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Rebel XS saying busy and won't take pictures

mliz2486
Contributor

My camera worked fine the other day.  Now, it won't take pictures at all.  When I go to take a picture, it will act like it is focusing by flashing and such but it will never go through.  It always says busy.  I have tried all modes, and none will work not even without flash. 

 

I have also taken the battery out, taken the card out and reformatted it, and cleared all camera settings.  Can anyone help?  I have a newborn that I would really like to be able to capture. 🙂

 

Thank you ahead of time!

156 REPLIES 156

My fix to this problem was repair at $270, which was a new main board.  

Could it be that your camera is trying to tell you that whatever combination of lens aperture, shutter speed, and ISO you have set indicates that there is not enough light for careless handheld image capture? A case of toooo much automation. The flash symbol could indicate the camera believes you should use flash for a correct and sharp image capture.

Thelay
Contributor
Thank you so much. Will try those once i get home and will let you know again. 😊

Thelay
Contributor
Hello. Just an update. Tried to have my lens sent to service center and After 2 wks. My lens is working fine. I just hope the prob won't happen again. 😉
Thanks again to canon gurus for the work around. 👍🏼

That's great everything is working again. Thanks for the update.

Have a wonderful Thanksgiving and take lots of pics.

hannahcbettis
Apprentice

hi all,

 

I'm having the same issue on my rebel t3. it will sometimes not take a photo and says that it is 'busy' when I try to take the photo in auto modes. this doesn't happen all the time and this doesn't happen in similar lighting conditions. I'm using a tamron 18-270 on it now, but I've tried it with a 50mm and the 18-55 kit and that doesn't make a difference. please help! 

Do you have a Class 10 card in the camera that has been formatted IN the camera?

hi, 

 

yes, I do have a fairly new Sandisk class 10 card that was formatted in camera. actually after formatting in camera that fixed my problem, but now there is a dot that will flash next to the max burst rate 9 when I press the shutter button. any idea what this is? 

 

thanks!

Glad your camera is working again. Thanks for updating this thread so others can see your successful solution.

Check manual about burst rate light because I bet it's not just the camera saying "hello".

@hannahcbettis


dot next to max burst # is the Focus confirmation light..  It lights when camera perceives auto focus has been achieved.

Mamiya Super Press 23, Minolta SRT 100, 101, & 102, Canon AE-1,
Rebel T5 EF-S 18-55mm IS II & EF 75-300mm f/4-5.6 III Kit Refurbished $260
As Seen on TV, It's Not for Me
Avatar
click here to view the press release
Announcements