cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS RP: Changed a setting that blanked my touch screen. Now I can't undo it.

FernandoP
Apprentice

I love my EOS RP (had it nearly a year), but every now and then I hate it. I'm in hate mode. I was changing settings in the wrench menu and managed to changed a setting that blanked the touch screen. Now I'm stuck because the screen won't display the menus.

I've tried turning the camera off and on. I've tried removing the battery and replacing it after 5 minutes. Still no joy.

Any suggestions?

1 ACCEPTED SOLUTION

Anonymous
Not applicable

Something else to try. You should see the menu in the viewfinder. Go to Display Settings, then select auto for Display Control.

Screenshot 2023-09-17 183407.jpg

View solution in original post

8 REPLIES 8

Anonymous
Not applicable

Is your lock switch set to on?

Also, here are the menu settings where you could have disabled the touch screen found in your manual:

Screenshot 2023-09-17 174915.jpg

How do I do that with a blank screen? Normally, resetting the camera back to default is a menu item under the wrench menu. But with no access to the menus because the touch screen is blank, I'm stuck. 

Anonymous
Not applicable

I took it to mean that your touch mode was disabled. What you mean is that your screen is blank.

FernandoP
Apprentice

Thanks. The lock switch is off. By "blank" I mean black. Nothing to see. 

Anonymous
Not applicable

What mode is the camera in? Try P mode and see if that makes a difference. When you press the menu button, nothing shows on the screen? Are you able to review photos that you have taken?

Anonymous
Not applicable

Something else to try. You should see the menu in the viewfinder. Go to Display Settings, then select auto for Display Control.

Screenshot 2023-09-17 183407.jpg

FernandoP
Apprentice

That's the solution!  I didn't realize the menus would show up in the viewfinder when the "menu" button was displayed. That allowed me to returned the display settings to "auto" from "manual", and the screen came back.  

For the record, I also tried almost every mode and every button and  nothing would display on the screen. It was well and truly black. (Couldn't review images).That was weird! I'll have to read-up on the "manual" setting. 

 

Thanks for your help!

 

Anonymous
Not applicable

You're welcome. Glad it is now working.

Avatar
click here to view the press release
Announcements