Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon T50 Exposure counter (New to film photography)


I recently received a Canon T50 35mm film camera, it's in pretty good condition and everything seems to be working fine and there's no sign of corrosion and very little wear on the outside and none on the internals. Currently the exposure counter is stuck at 6, opening the back part of the camera doesn't reset it, I tried gently pushing the little metal piece on the top right corner on the back of the camera and I also tried dry firing it. Not sure if I need to put in a roll of film for the counter to start moving, I just wanna reset it or atleast know the exposure counter works. If anyone have experience with the T50 film cameras, I would really appreciate your knowledge! 🙂



Hi and welcome to the forum:
What I would suggest if getting hold of a roll of exposed or redundant film, loading it into the camera and trying it with the film loaded.  I shot film for decades and generally found that there has to be film in the system to activate the counter feature, but I have not shot with the T50, so I think an experiment should tell you one way or another. If it is an issue, you can open the back up and you are not ruining a good film.

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris


Hi Trevor,
I did try loading an exposed film to see if the counter starts moving, thankfully the camera operates properly and everything moves and works in that satisfying motorized sound, but the exposure counter still hasn't moved. I've never opened up a camera before, its daunting at first but a few screws to remove most of the camera casing and I found the problem, the lever that actuates the exposure counter was off-set transversely which explained why I was not able to reset the counter even by pushing the metal plate on the back. Anyhow once I tapped it very lightly it reset, now its working as intended. Thanks again for the advice, I wouldn't have been able to muster up the courage of opening the camera up without your response!

Enter for a chance to win