cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R8 cannot connect to cell phone after updated to firmware 1.2.0

Cheidi
Contributor

 

Failed to connect my Android phone with the camera after updated to firmware 1.2.0.  no problem before update. 

1. Paired using Bluetooth, attempted to dowload pictures but it switched to wifi connection and failed. 
2. Connect using camera access point mode, it keeps telling "could not connect, check password". But the password was correct!

I've re-registered the camera in Camera Connect, re-established the connection etc. but still got the same problem.

I then uninstall and reinstall Camera Connect, reset communication setting at the camera but it's even worse. Now I can't even register the camera. It doesn't respond when I connect using Bluetooth.  Connect via wifi got the same problem. 

Steps:

Select Advanced Connection --> connect to smart phone --> add a device to connect --> select wifi network --> enter password --> got l message "cannot connect to wireless LAN terminal". 

I'm sure the password is correct.

Is it a problem with the firmware? 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Thanks for the suggestion. However there is no option to turn off the password in eifi setting for R8.

Inspired by this suggestion, I used Manual setting to connect camera as AP, set encryption to none. Then it connected. Tried 3 times all working. 

View solution in original post

7 REPLIES 7

shadowsports
Legend
Legend

Greetings,

Troubleshooting steps:

Reset the connection settings on your camera.

Forget the camera profile in the Canon Connect App on your mobile device.

Here are the connection instructions for the R8

Canon Knowledge Base - EOS R8: Connecting to a Smartphone or Tablet

Note:

Once the camera is broadcasting its SSID, open Settings > Internet on your mobile device and confirm you can see the wireless broadcast from the camera.  Example (R8_2F3CDD_CanonOA).  Select this Wi-Fi broadcast and enter the password.  Once the devices pair, a profile for each is saved, on the camera and on the mobile device.  On subsequent connections, you only need to tell it what device to connect with.  A profile will already exist.

If you do not see the cameras SSID broadcast as a selectable network on your mobile device, check the camera.  Wifi is not properly configured, is not turned on or is not broadcasting.  Airplane Mode keeps the camera from broadcasting.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I've kept trying and fully aware of the steps to connect.

There are 2 ways to connect the phone and camera.

1. Use the camera access point mode

I was able to find the camera from wifi setting. However it keeps saying "Check password and try again". I've tried this at least 30 times, no way the password was wrong every time.

2. Connect the phone & camera in the same network

This goes through Bluetooth pairing then the app Camera Connect switches to wifi when I attempt to access the camera. It is very unstable, once in a while it can connect, most of the time it just say Connection fail. 

I've reset communication setting and re-pair the device many times. 

Another forum member recently found a solution to his “password” issue.

—————————————-

9910C356-8E22-4E20-BCFB-8EDB629FB2AC.jpeg

--------------------------------------------------------
"The right mouse button is your friend."

Thanks for the suggestion. However there is no option to turn off the password in eifi setting for R8.

Inspired by this suggestion, I used Manual setting to connect camera as AP, set encryption to none. Then it connected. Tried 3 times all working. 

shadowsports
Legend
Legend

Hi,

Are you using default settings?  The SSID name, WPA encryption and password generated by the camera.

You are correct about the 2 connection types.  Camera as AP or connect each to the same network.  I've tested both.  I have 2 devices Pixel 6 & 8,  Android 14.  I tested using the December security patch and just updated to the Jan patch.  Its unrelated to any connectivity.   Small 25mb CVE vulnerability (privilege escalation patch), working fine after this as well.

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks. I used default settings to connect but failed. It's a Pixel 6 android 14.

Inspired by the suggestion of setting password off, I used Manual setting to connect camera as AP, set encryption to none. Then it connected. Tried 3 times all working. Excellent accessing speed too. 

 

BTW I have no problem with my 80D connection.

Announcements