cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R5 Button Assignments

Fay
Contributor

Hello and thank you for your time. I have two R5 bodies. Right after getting the bodies, new, I set up some different functions on various buttons. Yesterday and today, I set C1-C3 custom setting on the mode button. Those work as advertised when I use the mode button. I wanted to change the AF-On button to bring up the mode screen. Mode was in the setting menu as an option of the AF-On button. I used it to test, and it brought up the Mode screen and I could select the mode I wanted with the toggle button to the left of the AF-On button. When I retried to see that the C2 and C3 settings came up correctly the button had reverted to what was originally set. This happens on both bodies. I have removed the battery, turned on the body, held the shutter button down for several seconds, and reinstalled the battery. That did not help. Any ideas would be appreciated greatly. I am missing to many shots as I trying to quickly to from different scenes. Again, thank you. Fay 

1 ACCEPTED SOLUTION

p4pictures
Whiz
Whiz

Each of the custom modes C1 / C2 / C3 have different custom button settings. So for example you can have AF-ON configured as AF-OFF in C1, AE-lock in C2 and FEL in C3.

Change to the C2 mode, then go to the setup menu SET UP5, select Custom shooting mode (C1-C3) and ensure that auto update set is enabled. This is so that any changes you make while using any of the custom modes is saved, updating the stored settings.

Now go to the customise buttons on the C.Fn3 page and do the configuration for the AF-ON button to do what you need. Then switch to C3 mode and do the custom buttons configuration again. If your auto updates were previously disabled then go to the SET UP5 menu and disable auto updates again.

Actually since your have two EOS R5 cameras, then once you have done one camera, you can save the camera configuration to a card, then simply load it on to the other camera ensuring that the settings are the same for both.


Brian
EOS specialist trainer, photographer and author

View solution in original post

3 REPLIES 3

shadowsports
Legend
Legend

Greetings,

For everyone's benefit, can you please explain clearly and concisely what you are trying to do?  You want to program the Drive Mode menu to appear when you press the AF-On button?  What reverted exactly, and to which setting.  What was originally set?

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

p4pictures
Whiz
Whiz

Each of the custom modes C1 / C2 / C3 have different custom button settings. So for example you can have AF-ON configured as AF-OFF in C1, AE-lock in C2 and FEL in C3.

Change to the C2 mode, then go to the setup menu SET UP5, select Custom shooting mode (C1-C3) and ensure that auto update set is enabled. This is so that any changes you make while using any of the custom modes is saved, updating the stored settings.

Now go to the customise buttons on the C.Fn3 page and do the configuration for the AF-ON button to do what you need. Then switch to C3 mode and do the custom buttons configuration again. If your auto updates were previously disabled then go to the SET UP5 menu and disable auto updates again.

Actually since your have two EOS R5 cameras, then once you have done one camera, you can save the camera configuration to a card, then simply load it on to the other camera ensuring that the settings are the same for both.


Brian
EOS specialist trainer, photographer and author

First thank you for your response. Second I am sorry it took me so long to respond. I have been very busy. 

It worked. Thank you so much for the help. 

Announcements