Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R not detected by PC via USB - Windows 10


I'm trying to connect my camera to my laptop to transfer my images. This has worked with all my previous cameras (DSLR), but with this one, Windows does not display it in the file manager. It does nothing.

Yes I've looked at other posts regarding this and no it has not solved my problem.

I've tried 2 different USB-C cables, and one USB-C to USB-A cable. I've tried all the USB ports on my laptop. I've tried with a different computer running Windows 11. All these cables, ports and laptops are working fine when connecting other devices.

I don't have an SD card slot in my laptop, nor do I want to use an external card reader There's a USB-C port on this camera, so there should be a way to connect it to my laptop no? What am I missing?

Thank you.



I called Canon support and they kept telling me that I needed their USB-C cable that's way too expensive, and I kept telling them that a USB-C cable is a USB-C cable, and that I tried 3 of them, and they all work with other devices but not my EOS R, but they would not let it go.

So I went to a local camera store to test the Canon IFC-100U cable that looks to me like a normal USB-C cable with two ferrite beads, and guess what? It's working!

I'm at a lost for words. I'm not an electronic expert, but apparently the Canon's USB-C cable (with its ferrite beads) is different enough from all the other USB-C cables I have, and with this one it works. So I bought it and everything is fixed. I still don't understand why thought.

Thank you all for your good suggestions!

View solution in original post



I assume that your USB cable is a data cable that works.  At the very least, Windows should make that “bippity-boppity-boop” sound after you turn ON the camera after you plug it in.  It should also make a sound when you turn the camera OFF, too.

Go into the menus and check the communications mode.  Make sure wireless communications are disabled.  The camera cannot switch between wireless and USB on its own.  You would not want it switch on its own, either.

One some new installs of the EOS Utility you need to go into the Programs/Canon folder and manually start the EOS Utility 3.  This “jump start” should only need to be done once.

"The right mouse button is your friend."

Thank you for your reply. Windows does make the “bippity-boppity-boop” sound after I turn ON or OFF the camera.

I've disable the wireless communication on the camera. EOS Utility is up to date and I started manually like you suggested.

However, it's still not working. The camera displays a computer on its screen, but EOS Utility doesn't see the camera, nor is it showing in the file manager. I really don't get it.

The cables I have are working for other devices, but I've ordered a couple of new cables from Amazon (Anker), I'll come back in a couple of days to let you know if it changed anything.

When you start the program manually, show me a screen shot of what you see.  

What is the name of the app that you are starting up?  Is the EOS Utility 3 starting up and opening a Dialog Window?

[EDIT] If Windows should prompt you as to what to do when it detects a camera has been connected to the USB port select “Take No Action”, which allows the Canon EOS Utility Launcher Service to take control of the USB port and the camera.

"The right mouse button is your friend."

If you have Wi-Fi disabled in the camera, and you are hearing the USB connection tone when you connect the camera to the computer, you should see in File Explorer a folder starting with Canon EOS. That would be your camera memory card. You can open that folder to see the contents of the card. Don't run the EOS Utility while doing the above. Also make sure that the camera doesn't go to sleep, you may have to half press the shutter button to wake it up.

Canon 5D Mark IV / 5D Mark III / 6D / 80D / Speedlites / Lenses


Thank you all for your replies. So far, still not working.

EOS Launcher is running and doing nothing, not detecting a camera.

EOS Launcher.jpg

I manually started EOS Utility 3 (C:\Program Files (x86)\Canon\EOS Utility\EU3\EOS Utility 3.exe) and again it's doing nothing, not detecting a camera.

EOS Utility 3.jpg

All programs are up to date, and Wifi is disabled on the camera. The camera displays this:

Canon Screen.jpg

When I plug in the camera, I get the Windows USB sound, but Windows does not prompt me as to what to do when it detects a camera, and there is no drive mounted in the file explorer starting with Canon EOS or anything else. If I plug in my phone using the same USB port, I see it in the file explorer.


I have found something worth mentioning. In Windows' device manager, the camera appears under Portable Devices as MTP USB Device and not as "Canon Something" as I believe it should. Can anyone confirm how it's displayed in your device manager?

Device Manager.JPG

I tried uninstalling the device then clicking "Scan for hardware changes", but it always comes back as this MTP USB Device.


This is mine with Windows 10 and a EOS 6D camera. Were you able to try another USB cable?

Here is a link concerning MTP issues with cameras: 


Canon 5D Mark IV / 5D Mark III / 6D / 80D / Speedlites / Lenses


“ I don't have an SD card slot in my laptop, nor do I want to use an external card reader There's a USB-C port on this camera, so there should be a way to connect it to my laptop no? What am I missing? “ 

It sounds like a possible hardware issue with either the camera or the laptop.  Have you tried to remove and reinstall the EOS Utility, yet?

What brand of laptop are you using?  Does it use an Intel chipset?  There have been known compatibility issues with AMD chipsets.  Upgraded Operating Systems are not fully supported, either.

"The right mouse button is your friend."


I've tried 2 new USB-C cables from 2 different brands (both new).

I uninstalled and reinstalled EOS Utility.

I've tried all the steps in the link above about MTP issues with cameras.

Nothing is working so far.

I wrote to HP support, they said it's too complex and I need to call them but I don't have the time today to be on hold forever. 🙂

My laptop is a HP Spectre, 11th Gen Intel(R) Core(TM) i7-1165G7 running Windows 10 (I haven't upgraded to Windows 11 yet).

My next step is to install EOS on my daughter's laptop and see if it works. I'm pretty sure it was a Windows 11 install and that she didn't upgrade to Windows 11 but I'm not 100% certain, so what do you mean by "Upgraded Operating Systems are not fully supported"?

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5