Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS R Keeps Freezing!!


I purchased my EOS R back in October of 2018 from a local camera shop. Up until recently, my EOS R had been working perfectly. Recently, I started having an issue where my EOS R will freeze while using the camera. I have had the issue multiple times, and the only way I am able to get the camera to work again is by removing the battery and waiting a few seconds before inserting it again. When the camera is frozen, none of the buttons will work, and the on/off switch will not turn off the camera. The camera has the latest firmware installed (1.2.0). I am also using the lens that came with the camera (24-105 f/4 RF). The lens also has the latest firmware installed (2.0.0). I have tried using multiple batteries (Canon brand) as well as multiple memory cards, with no luck.



Did you reset the camera?


Are you using a micro card with adapter or a full size SD card?


Call Canon, it sounds like it needs service.



Seems to be a common issue with EOS R. One guy at Dpreview got this answer from Canon support:

"This could be a memory card issue if you are using the Ultra cards and shooting with HDR or Dual Pixel RAW enabled..."

He did have Ultra but he didn't use HDR or Dual Pixel Raw.


Another user:

"Used to have freezing issues until I upgraded to the newest firmware that came out a few months ago. Been solid since.

Edit: actually I changed to a Sony Tough card around the same time, when before I was using ultra cards, that could have been it too."


Just discovered the exact same problem by chance, kinda brand new body, original Canon batteries w/ battery grip, EF R 24-105, no matter what memory card. Showed up all the sudden, drove me nuts...

Checked and tried all kind of things, and hooray, seems I've found the cause: Disabled the automatic power off feature in the power saving options, problem seems to be gone.

Have indeed played around with settings in power saving options before problem came up, so this really seems to be linked.


ive been having same problems have you found a solution ?

It it were me having this issue I would immediately call Canon tech support.  After getting the issue resolved with tech support and would then post the solution on here to help others.



Yep, me too, in Australia. latest firmware. Camera freezes every few shots - have to turn off and remove battery to get going again - when shooting models with active tracking [if that has anything to do with it?] Have contacted Canon and are awaiting a fix. What a nightmare!

Did they say what the problem is? 

Product Expert
Product Expert

Hi hilliamonk,


Thanks for checking in with us!


In addition to some of the other points mentioned on this thread, it might help to pay attention to the camera buffer. As you may have learned, when you're taking shots, the images don't go right to the card. They go to the camera's short-term memory, also known as the camera buffer.


When the camera buffer fills up, the camera will pause for a few seconds as the data is transferred to the card. At this point, you will not be able to fire any shots on the camera. You'll want to wait for the blinking to stop before you switch cards or batteries. Otherwise you risk the possibility of corrupted data.


You can tell how many shots are left in the buffer by referencing the number on the bottom right in the viewfinder. Once that number reaches zero, then you won't be able to fire any additional shots for a few seconds. If you are waiting for an important moment to photograph, be mindful of the shots remaining in the burst.


If problems persist, please elaborate on your camera settings, what you're shooting when the issue comes up, and which memory card and accessories you're using.

thanks - im a slow shooter, 1 shot / 5 sec so its not buffer - settings: firmware 1.6 - shooting with eye detect, continuous AF, single shooting, one shot, Sandisk Extreme Pro UHS-1 95 MB/s - no error msg but I didn't look inside the view finder - then I notice others who have this prob do see a error msg in view finder saying turn camera off and pull out battery....I'll try reformat card, then a different card perhaps...???