Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 5D Mark IV not triggering Godox Xpro & Godox V1-C


Im having issues with firing my flash. ive used to a good amount of times before but as of the last time I was shooting the flash stopped firing. As since I can only get it to fire a few times in "ETTL" mode but in Manual the flash is not firing at all. I have made sure to disable silent live view but it still will not fire, in live view or through the viewfinder nothing is working with the trigger OR with the flash mounted on the camera. any ideas?


Not applicable

Do you have another flash to try mounted on your camera? If another works, then your Godex flash would need servicing.

Tried other one, nothing firing as well

Not applicable

Do you have flash firing enabled in the camera's menu?


Not applicable

Do you have wireless flash enabled in the camera menu? What brand and model is your second flash?

where is this?

Not applicable


What brand and model is your second flash?

It is in the red #1 menu, under External Speedlite control. If you have a Canon flash attached, you can set wireless functions there, or on the flash itself. The menu will only show this with an attached Canon flash.

Yes I did have it on, update I put the trigger on my old canon 5d mark ii and it worked fine so theres something on the mark iv thats not communicating 


Have you tried a Canon speedlite to verify that the camera is communicating with the speedlite.


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D
Enter for a chance to win