cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 1D-X/LP-E4 Charge/Battery Issues

JohnV67
Contributor

Long story short, a "new-to-me" 1DX has some mild battery issues. (Bought from KEH)

Upon inserting the battery for the first time - nothing. Not even the flashing dead battery indicator.

Put it on the charger, didn't do anything for about a half an hour and then started charging.

Went out to shoot a game to test out the new camera - battery worked as normal for about an hour and then started going out. I'd take a few shots, then the dreaded "dead battery thunk" of the shutter and the whole thing would turn off. However, switching it off for 5 seconds and then turning it back on makes it work only for the problem to recur a few shots later.

Can anything be done about the issue, or am I in the mud for a bit? Normally wouldn't be a big deal but I was called to shoot some things in the next couple days and feared I couldn't get a new one on order in time.

Lens used was a 200-400 f4L 1.4x.

 

3 REPLIES 3

deebatman316
Authority
Authority

Have you tried a different battery. As batteries age they loose capacity and they fail usually when your firing a burst of shots.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

Sadly I do not have any spare e4n cells to test it with.

This is what the problem is more than likely. You can buy new batteries to test if the camera continues to act this way.


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D
Avatar
click here to view the press release
Announcements