cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connecting to my MAC

mcg77
Contributor

super SLR newbie here. Bought myself EOS rebel T6 and I put in my USB port and nothing is happening. USB port is working because I have  had other things plugged in before. I downloaded EOS utility but i cant get connected. Dont know what I am doing wrong.Any suggestions?

8 REPLIES 8

Stephen
Moderator
Moderator

Hi mcg77!

 

Thank you for reaching out to us, we're happy to help!

 

So that we can give you the best answer, are you using a Macbook or an iMac? Which version of macOS are you running? 

 

We have found *sometimes* if you're using a Macbook, the laptop needs to be plugged into its power supply to be able to give the USB ports enough power to initiate a transfer. With an iMac, you need to make sure to plug the USB cord directly into the back of the iMac and not into any hubs or other devices (like the keyboard). Again, Macs try to be power conscious and this can *sometimes* cause issues with the USB ports. 

Another thing is the battery to your new Rebel T6 needs to be fully charged by removing the battery and inserting it into its included battery charger that plugs directly into the wall. You'll also need to turn your Rebel ON when you plug it. That will initiate the transfer process. 

 

If you've done these things, and you're still running into problems, don't hesitate to get in touch with our US-based technical support team. They're 100% free, and well-versed in using the Mac OS. They're available by phone at 1-800-OK-CANON (800-652-2666) during the week from 8am to Midnight (ET) and on Saturdays from 10am to 8pm (ET). They're also available by email anytime at http://Canon.us/EmailCF

We hope this is helpful!

Thanks for getting back to me. I have a MAc Book and the operating system is OSx. I had done everything you metioned, everthing turned on and plugged in. Sigh. I will give the support group  shout later

Make sure wifi on the camera is turned off.  It won't recognize the USB connection if wifi is enabled.

mcg77
Contributor
Stan, you da best. Thank you!!! 😄

Ask me how I know this.  🙂

mcg77
Contributor
Ummm, how do you know this?

🤣😂

hmmm

Avatar
click here to view the gallery
Announcements