cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon T2i wireless shutter release

Gerryyy
Apprentice

Hi All,

I just purchased a Vello Freewave Plus wireless shutter release.  My only issue with it and my T2i is that there is a 10 second delay from when I press the remote shutter release and when the camera fire.  I believe it's something to do with the camera as the 10 second delay counts down in the lower right of the rear screen.  Any ideas of how to turn 10 second delay off?  TIA.

5 REPLIES 5

ebiggs1
Legend
Legend

Reset the camera.

Under the [wrench] tab, select [Clear settings], then press <>.
Select the desired setting.
To revert the shooting settings to the default, select [Clear all camera settings], then press <>.
To revert the Custom Functions to the default settings, select [Clear all Custom Func. (C.Fn)], then press <>.
 Select [OK].
Select [OK], then press <>.
Setting [Clear all camera settings] will reset the camera to the default settings.

 

You must be in the <P> or other Creative Zone modes to do this.

EB
EOS 1DX and 1D Mk IV and several lenses!

I did the clear over the weekend.  I think it solved my 10 second dealy.  Thanks for the tip.

jrhoffman75
Legend
Legend

Check if this setting is enabled.

Screenshot 2022-09-14 132524.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Gerryyy
Apprentice

It wound up being the clear function that helped me.  Thank you for your suggestion.

Clear will wipe out all settings, so be sure to re-establish the ones you want. Particularly the one that won’t allow you to take photos without a card. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Avatar
click here to view the press release
Announcements