Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon SL2 Microphone - External


I have a brand new SL2. I am trying to setup an external lapel microphone. When I do that, my screen shows three ahlf circles, theicon of a mic, and the word "off" next to it. I cannot seem to get to microphone settings. What am I doing wrong?




Just to share, I found a TRSS to TRS adaptor and that did the trick - bottom line is - the original 3.5 mm (TRSS) had three small rings (4 poles) while the TRS only has two rings (3 poles). Once I used the 3 poles (TRS) the issue was resolved. I hope I got that right 🙂


Thanks all for the good advice!   

View solution in original post



I don't know if this is the problem, but often "advanced settings" are only available in one of the "Creative modes", like P.


Try setting the camera to P or M.


(You can tell if this is the case since the manual will have a * by the setting.)

I had it in M - I found where I can see the levels of the mic, but it just shows no activity at all. I know the mic works as it is the one I have used before with my Canon Vixia video camera. I have also read that the SL2 does support lapel mics. Not sure what I am missing. 

Consider the source, as I have no experience with video recording. But could this be a case where the microphone expects to draw power from the camera but the camera is incapable of providing it?

Philadelphia, Pennsylvania USA

It could be. What I am surprised is that the camera is well-known as a great "vlogging" camera. I would imagine it would support most mics .... but yes, good point. I'm hoping someone who has tried this before may have some insight. 

Which mic do you have?

Have you tried playing with the gain or attenuator settings?




Yes kvbarkley- but once I plug in the external mic., I get no signal, but then I was reading about a TRS adaptor - I wonder if I may be needing one of those (?) 

I was thinking that, if you have a mono mic, you could be shorting one side, maybe both if you don't push it all the way in.

Right - that may be it. I will try and find an adapter and give it  try. I know for a fact it was pushed all the way in .... believe me, I tried! 🙂