cancel
Showing results for 
Search instead for 
Did you mean: 

Canon Rebel locks up,

Mindhack
Occasional Contributor

 Hey guys! This is my first post so let me start off by saying, greetings! But now to the meat. I have a Canon Rebel t3. a few days ago something really weird happened. I hope maybe somebody had a similar experience, and figured it out. Ok, whenever I take a photo (and seems as if it doesn't matter what mode. I've tried this in landscape, portrait, no flash, with flash, autofocus on, manual focus on, etc) the same fires, but then instantly locks up. The screen goes black. None of the buttons respond. And the little red LED comes on and is solid. There is no way I've found to get the camera out of this 'dead-mode' except for doing a battery pull. If I open the battery lid, the camera beeps I guess to warn me that I'm about to pull the battery while it's on. So I suppose it is 'on' but it's in the dead state I just previously described. So I pull the batt and put it back in and the camera comes back on. The screen works. And all the menus and settings are accessible. If I check to see if that photo I just tried to take was recorded, it never is. All my old photos I took BEFORE this weird circumstance are still saved. So If I go back and try to take a photo the cycle starts again. The camera fires, the screen blacks out, the red LED is solid, none of the buttons are responsive. Even flipping the on/off switch to the 'off' position and then back the 'on' position has absolutely no effect. So I have to pull the battery and that wakes the camera up. How weird is that? I don't have very much experience with cameras but this is what has happened to me. I've tried to include all the relevant information. If I left anything out please ask me and I'll be glad to try and fill in any holes. But uhh, does anyone have an ideas as to why this is happening? or how to fix this? I really wanna take pictures and it defintely sucks not being able to. Thanks in advance for any help.  

14 REPLIES 14

Mindhack
Occasional Contributor

Just wanna start off by saying thanks for sticking with me ScottyP. Funny thing is I've learned more about this camera just from this whole troubleshooting process. So I really appreciate that assistance. But yeah, when I say i'm manually focusing I switched that little switch from AF to MF so I can turn the little slender knob at the very end of the lense. It took me a little bit but I found the 'reset settings' option. It's in Setup Menu 3, which apparently can only be accessed from one of the advanced exposure modes. So I reset the settings, and theres an option under that for 'reset custom settings' I reset that as well. Unfortunately taking a photo in the green box mode or the P mode produced that same results. Although I didn't try the M, AV ot AV modes. 

Mindhack
Occasional Contributor

Just an update. A friend of mine that works at the apple store (not that that has anything really to do with this, just saying that to give a little context) is a photography enthusiast. After telling him my situation he asked me a couple of questions about the battery pull. After I told him, he suggested that when I pull the battery to leave it out of the camera for 15 minutes. After that, then put it back in and try to take a photo. I'm not home now, but I'll definitely give that a try and keep you guys posted. I hope this works though. I'm really stumped on this one. 

Mindhack
Occasional Contributor

An update, the 15 minute battery pull did not work. pretty lame. But that same individual suggested maybe trying to use the EOS utility and try the 'remote shooting' option, to see if the camera will write to the computer. I'll have to try this when I get home. 

Hi there,
I have a T4i/650d and just encounterd the exact same problem:
1. Camera stucks after trying to take a photo.
2. Camera stucks when switching to live view.
3. Camera stucks when switching to video mode.

The only thing i can add is that in all modes i can see and hear the mirror go up and get stuck there.

Did the settings reset and it didn't help much.

Thanks!

ImBatman
Occasional Contributor

I have a Canon EOS T3 (1100D). Here's how I FIXED THE PROBLEM!

 

BACKSTORY:

I know this is late in the game (2 years?) but here's a fix for anyone looking. I had the same problem and it turned out to be the memory card I was using.

Somewhere online I read that you need a "Class 10 or better" SDHC card. And on here someone said you have to use an "SDXC I" card, not SDHC. Well I was using a "SanDisk Extreme, 64GB, Class 10, 90mb/s, SDXC I" and I still had that problem. 

 

SKIP TO THE FIX: 

I tried using a regular old SDHC card and my T3 is working perfectly in all modes now!

 

Cards I've tried that work for me:

SanDisk Ultra, 32gb, 15mb/s, Class 4, SDHC

Panasonic, 4gb, Class 4, SDHC

Kingston, 2gb, SD