cancel
Showing results for 
Search instead for 
Did you mean: 

Canon Rebel Ti images showing only as icons

Aelk
Contributor

I just transferred my images from an old computer to a new one.  All of the photos that were originally uploaded from my Rebel XTi are only showing as icons and are not viewable.  I do not have the Rebel software installed on the new computer just the software for my 40D, could this be why?

9 REPLIES 9

hsbn
Whiz

What is your OS? What software do you use to view your image?

--------------------------------------------------------------------------------------------------
Weekend Travelers Blog | Eastern Sierra Fall Color Guide

TCampbell
Elite

I'm guessing you're probably using RAW and have not installed the Canon utilities on your new computer.  

 

You'll want to do two things:

1)  Using the disk that came with one of your cameras, install the Canon utilities (EOS Utility, Digital Photo Professional, Zoom Browser, etc.)   It actually doesn't matter which disk you use to install (you can use the disk that came with your XTi or your 40D).

2)  Go to the Canon support site and download the latest version of these apps.  You can navigate to the product page for either camera (e.g. http://www.usa.canon.com/cusa/support/consumer/eos_slr_camera_systems/eos_digital_slr_cameras/eos_40... )

 

The reason you needed to install the base version is that some of these downloads are not the full product... they're "updates".  Both the EOS Utility and Digital Photo Professional require that you have a base version installed, then you can apply the update.  This will bring you new computer up-to-date with the latest features of these apps including the ability to view and open the RAW images created by these cameras.  

 

If you were using something else to view and edit your images (e.g. suppose you had installed Photoshop) then you would have to install that software on your new computer and would also likely need to check for updates from them as well.)

 

JPEG is a fairly universal format -- so it's rare to find any computer that can view JPEGs.  RAW, on the other hand, is more of a "concept" than a "standard".  

 

Each camera can have it's own RAW format.  Consequently, each device that wants to view the files in the native RAW format has to understand that specific RAW format.

 

Apple simplifies this... they provide "Camera RAW Updates" at the operating system level which means that the computer does understand (and can open) any of the RAW images even without installing any specifial software.

 

Windows is a different story... Microsoft does not provide any sort of RAW support at the operating system level.  Instead, you have to get RAW support from 3rd parties.

 

The Canon utilities provided with your camera will know how to open and view any of the photos taken by your camera provided you installed those Canon utilities.  If you use Adobe software, then you'd have to install the RAW updates provided by Adobe.

 

RAW images typically contain a small JPEG "preview" image embedded within the RAW file.  Many computers and applications that see the JPEG preview even if they can't actually open the full RAW file.

 

 

Tim Campbell
5D III, 5D IV, 60Da

Aelk
Contributor

My OS is Windows 7 Pro.  I have all of my canon viewing software on my computer: Digital Photo Professional, EOS Utility, Picture Style Editor and Imgae Browser EX.  There is one icon that shows up when there is a raw image but this new icon I am worried about seems to be attached to JPG files.  I also have a canon point and shoot camera that I have for everyday stuff.  Maybe those are the ones that aren't showing up?

Aelk
Contributor

canon problems.PNG

 

This is the icon

Ah - if these are JPEG (.jpg) images, then this is a simply a Windows preference that you have set.

 

In the Windows Explorer (the Win 7 file manager), there's an "Organize" menu near the top left area of the window.  Pick that and it'll expose a pull-down menu.  

Choose "Folder and Search Options" off that menu.  This will open a small pop-up window.

Choose the "View" tab in that pop-up window.

Near the top of the list (possibly the top pick) is an option that says "Always show icons, never thumbnails".  Make sure that box is _not_ checked.

 

Click "Apply".  

 

Tim Campbell
5D III, 5D IV, 60Da

Thank you for all of the help!  Unfortunately that box was not checked.  When I click on the icon to veiw in a photo viewer or try to open it in Photoshop the photo doesn't come up then either.

It sounds like something is wrong with the images.  JPEG is a universally recognized file format.  Photoshop would easily have been able to open them if they were JPEG.  I'm starting to suspect that these aren't really JPEG images.

 

Will the images open in Canon's "Digital Photo Professional" software?  DPP can open them even if they are RAW.  Photoshop can only open a RAW if your copy of Photoshop has the correct version of Adobe Camera RAW installed (which you can fetch through their software updates.)   

 

 

Tim Campbell
5D III, 5D IV, 60Da

No they cannot be oppened in DPP.  I went back to my laptop and discovered that they all have a padloc icon in the corner of the thumbnails, but I can see the thumbnails and the photos.  When I click on properties it shows the padlock icon and "share with no one."  If I attempt to share them with my home group (which I have no idea what a "homegroup" is) and then cancel it the padlock icon goes away.  Any ideas?  Am I going to have to do this with all of the photos?  They go from my most recent photos all the way back to May 2011.  I don't know why this padlock icon is showing up and only on select photos.

This sounds like a Windows permission problem.  I normally use a Mac so I'm not sure why you're getting that padlock and an error message that blocks you from opening or sharing them.

 

On Windows Explorer you can right-click an invidual file, go to the Security tab and view or change permission on the file, but I'm not aware of a way to do this in bulk (e.g. grab lots of files and change the permissions of all of them) -- at least not without dropping to a command prompt.  When you pick many files and select properties, the "Security" tab isn't available.

 

 

 

Tim Campbell
5D III, 5D IV, 60Da
Announcements