cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R8 Black LCD

BenjaminRyker
Apprentice

Usually, I can see the photo or scene on my LCD before I take it, but now all I see is a black screen. However, whenever I hit the shutter button to focus, it shows me the image before I take it, but then goes back to black. I'm so confused because I'm in a very well-lit room and have my ISO at 200 and shutter speed at 1/125th. I've never had a problem like this in my room before. I'm confused because I never changed my settings on the camera, and my camera was perfectly working yesterday since I took photos all evening yesterday. Does anyone have a fix for this, or is my camera broken?

IMG_0507.jpeg

IMG_0506.jpeg

IMG_0505.jpeg

  

1 ACCEPTED SOLUTION

p4pictures
Whiz
Whiz

Indoors with the exposure manually set to 1/125 f/5.6 and ISO 200 I would expect an almost black frame. Your camera is simulating the exposure and showing you the black result you'll get from the settings you have set. You can see EXP SIM on the right side of the display. You can also see that there is a small triangle under the exposure scale and it is fully to the left side indicating more than 3-stops underexposure.

There are two solutions;

  1. increase the exposure by raising ISO, reducing shutter speed or opening the aperture
  2. go to the menu search for Display simulation and turn it off

You might not have seen this kind of problem before if you were using another mode such as Tv, Av, P and or where using auto ISO, since in those situations the camera can make some setting adjustment to give a correct exposure. 


Brian
EOS specialist trainer, photographer and author
-- Note: my spell checker is set for EN-GB, not EN-US --

View solution in original post

4 REPLIES 4

Tronhard
Elite
Elite

Hi Benjamin and welcome to the forum:
Have you tried prodding the INFO button a couple of times.  If you inadvertently pressed it, you may have put it in a mode to not display the shooting in live view.  Failing that, have a look at the section in your manual for Shooting Information Display, on P312.  If you don't have it Google "EOS R8 Advanced User Guide".

As an aside, while it might be fashionable to compose and shoot by looking at the rear LCD, for still photography it is a much more stable platform to bring the camera up to your eye and thus get 3 points of contact.

00 Holding a Camera.jpg   How_to_hold_a_camera.jpg 


I always recommend that you download a PDF copy of the manual for reference, even if you have a hardcopy supplied as you can search for specific phrases.

 


cheers, TREVOR

"The Amount of Misery expands to fill the space available"
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

I was just showing you the issue, I don’t usually hold my camera that way, the only reason I did that was to capture photos of my camera with my other hand. Thanks for the reply though.

p4pictures
Whiz
Whiz

Indoors with the exposure manually set to 1/125 f/5.6 and ISO 200 I would expect an almost black frame. Your camera is simulating the exposure and showing you the black result you'll get from the settings you have set. You can see EXP SIM on the right side of the display. You can also see that there is a small triangle under the exposure scale and it is fully to the left side indicating more than 3-stops underexposure.

There are two solutions;

  1. increase the exposure by raising ISO, reducing shutter speed or opening the aperture
  2. go to the menu search for Display simulation and turn it off

You might not have seen this kind of problem before if you were using another mode such as Tv, Av, P and or where using auto ISO, since in those situations the camera can make some setting adjustment to give a correct exposure. 


Brian
EOS specialist trainer, photographer and author
-- Note: my spell checker is set for EN-GB, not EN-US --

Thanks for being so helpful. Turning off the Display Simulation fixed it.

Avatar
click here to view the gallery
Announcements