Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon R5 Live View not Reflecting Aperture Changes in Still Mode; Connection Issue with Laptop


Hello, photography enthusiasts!

I'm facing a couple of challenges with my Canon R5 and I'm seeking some advice from the community. Firstly, I've been encountering an issue where the Live View on my Canon R5 doesn't accurately reflect changes in aperture when I'm in still mode. Additionally, I'm experiencing difficulties connecting my camera to my laptop. Any insights or suggestions would be greatly appreciated.

Here are the details of the problems I'm facing:

  1. Live View and Aperture Changes: When I adjust the aperture settings on my Canon R5 while in still mode, the Live View display on the camera fails to reflect the changes accurately. This poses a challenge because it makes it difficult to preview the depth of field before capturing an image. I have tried adjusting the aperture through both the camera's control dial and the lens' aperture ring, but the Live View image remains unchanged. However, once I take a photo, the resulting image does reflect the correct depth of field based on the selected aperture.

  2. Connection Issue with Laptop: In addition to the aperture problem, I'm also unable to establish a connection between my Canon R5 and my laptop. I've tried using different USB cables, ensuring that the camera is in the correct mode for file transfer, and updating the necessary drivers on my laptop. Despite these efforts, my laptop does not recognize the camera when connected, and I'm unable to transfer images or control the camera remotely.

I'm wondering if these issues could be related to each other or if they are separate problems altogether. It's worth mentioning that I'm using an Ryzen AMD processor on my laptop, and I'm unsure if there could be any compatibility issues with the camera's firmware.

If anyone has experienced similar issues or has any suggestions or insights, I would be extremely grateful for your assistance. It's frustrating to encounter these problems, especially when they hinder the camera's functionality and my ability to work efficiently.

Thank you all in advance for your time and support!

Tammy Gombez




This is expected behavior.  The camera does not "stop down" until the photo is actually taken.  

See this:

Canon Knowledge Base - Aperture-Priority AE on the EOS R5.

You can use Depth of Field Preview just like the old days.

Depth of field preview and computer connectivity issues are separate / unrelated issues. If you are trying to shoot tethered, the same applies.  If you use Av mode and press the Depth of Field preview button, this will be reflected on the tethered device. 

Canon software is developed and designed for intel based hardware.  It can work on AMD based systems, but sometimes with unexpected or undesirable behavior.  I recommend Intel for the best experience.    

Note.  Watching your post. 2 new users and 2 nearly identical posts within 25 min of one another.  I'll edit my post if I find its just a coincidence. Please don't take this personally.  Its probably just a coincidence.  This is an inclusive environment, but we do get a lot of SPAM.  Your questions are valid and ones we are happy to help you with.   


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It


I realize this is an old thread, but just wanted to add that you may want to try removing your memory cards when trying to tether to your computer.

click here to view the gallery