Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS Rebel T3i (600D) won't record video and screen goes blank in priority/manual modes.


Earlier today I noticed that my camera wouldn't record video in Movie Mode. I had my 55-250mm lens on and wondered if this was a built-in setting (?) as I hadn't ever tried to record video with that particular lens. I switched back to my regular 18-55mm lens and it wouldn't work with that either.


After doing some searches online I tried to reset my camera's settings by going into Manual mode and going through the menu, but as soon as I clicked the selector dial over to "P" the screen shut off. Same thing for Tv, Av, M, and A-DEP modes...blank screen. Auto, Flash Off, Creative Auto, Portrait, Landscape, Close-up, Sports, and Night Portrait modes all work as they should.


Do I need to just bite the bullet and find a repair shop (or send it off to Canon...which seems expensive; website said about $200 without even knowing what the problem was), or is this a problem I can fix on my own? Has anyone else experienced this?





Hi nickalmand!


Welcome to the Canon Community.


In the P, Tv, Av or M modes, if you press the MENU button, does the menu appear on the screen?  Also, what specific memory card are you using in the camera while trying to record video?


If this is a time sensitive-matter, additional support options are available at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

No, nothing appears in those modes no matter what I push...MENU or otherwise. The memory card I'm using is a SanDisk 32GB card. It's not my main card (which I couldn't find in short time before leaving for vacation), but I plan to try that one when I can locate it. So far I've tried two cards (both SanDisk) but am having the same issues with each.


Note: This is NOT the "movie recording has been stopped automatically" issue that a lot of other people have when using media that is too slow. I am unable to record video at all. Meaning, when I press the record button nothing happens.


Additional issues I've noticed since my first post: 1) the message "This function is not selectable in the current shooting mode" is displayed in both normal and live viewing modes even though I'm not pushing any of the buttons that would cause this message to show and 2) when I'm viewing photos in "play mode" I can zoom in but not out.


Thanks for your reply.

Hey dont know if your still having problems but i was having the same thing happening. if you card is to slow it wont record long i had a samdisk micro sd HC 16 in it and it wouldnt work i put in a sandisk micro sd XC I if its a HC it wont work the buffering on it is to slow. find a XC I or like it need the speed for the high def video that it can shoot. i use a rebel T5. hope that helps any.

Hey, it was actually a different problem. I had media that had a sufficient transfer rate, so I knew that wasn't it. I actually had to send it in for repair and they said that the motherboard was faulty. After the repair it's been working fine.

How much did it cost? You're the only one I've found that has the exact problem I have. It's really difficult to know what to Google when you have such a bizarre problem.

You're exactly right! It ended up being a motherboard issue and cost around $150 if I remember correctly (it's been a while). Fair warning...they don't exactly keep in super close touch like they say (i.e. notifying you when your camera arrives at the repair facility...when they ship it back, etc.). Then I had to contact them to find out where my camera was because FedEx had apparently attempted delivery 3 times but left no note whatsoever.


Good news is that it works like new and I haven't had any problems since the repair.


Good luck!

Good to know.  Sent it in today and will see what they say.  On the bright side, a local camera shop has a used Canon T3i body selling for $200 currently so there's that option if the repair ends up being too pricey.  Thanks!


I have a Canon EOS T3 (1100D). Here's how I FIXED THE PROBLEM!



I was having the same problem! Except mine worked fine in all of the modes except for video (again, I'm using a T3, not T3i). The lcd display screen would just shut off and none of the buttons would work. Even if I tried to scroll to another setting (M, Av, Tv, P, etc.) after trying that video mode, nothing would happen. I think I could hear little noises that sounded like focusing or something sometimes, but other than that it was like the camera was completely broken. It freaked me out!


Somewhere online I read that you need a "Class 10 or better" SDHC card. And I see on here someone said you have to use an "SDXC I" card, not SDHC. Well I was using a "SanDisk Extreme, 64GB, Class 10, 90mb/s, SDXC I" and I still had that problem. I dont know about your fancy T3i's, but here's what worked for my T3:



I tried using a regular old SDHC card and my T3 is working perfectly in all modes now!


Cards I've tried that work for me:

SanDisk Ultra, 32gb, 15mb/s, Class 4, SDHC

Panasonic, 4gb, Class 4, SDHC

Kingston, 2gb, SD

click here to view the gallery