Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS-RP record button not registering (working)



Out of the blue my canon eos rp cameras record button stopped working. Been using it for almost 2 years without any issues. Tried a factory reset (thought maybe the record button somehow got re directed to another feature) a new SD card, and a new battery. Looked online and this doesn’t seem to be a common problem. Anyone have any advice or had this happen? Thanks in advance for any replies!!


Product Expert
Product Expert

Hi dborruel,

I'm sorry to hear the record button is not working on your EOS RP. When you press the record button do any error messages show on the camera, and if there is an error message what does it say word for word? 

There is one thing to double check with how you cleared the settings on the camera. If you only cleared the settings that would not reset customized buttons back to factory default. To clear customized buttons put the camera into either P, Tv, Av, or M and press the Menu button. Go to the Custom Functions tab (the orange camera tab second from the right), select Clear Customized Settings, and choose Okay. Using that option will clear customized buttons. Once you've done that check to see if the same thing is happening.


The same thing has happened with my camera. The record button stopped working and will no longer do anything. I thought maybe it was the battery running low so recharged it and tried again but still the same. I get a message displayed saying FHD 30P 0. I cannot get this to change.