cancel
Showing results for 
Search instead for 
Did you mean: 

Canon 5d MK IV ER 02 and coruppted videos

munder5066
Contributor

Hello,

I have this problem that happened yesterday, I was recording on my 5d mk IV and suddenly i had the er02 on screen that told me the memory is not accessible, I turned off the camera and restart it and try to play the movies and I had nothing on the preview on the camera, i checked the space of the memory it showed that it has 28Gb on it, when I checked the memory on the laptop it shows nothing in the DCIM-100EOS5D,

But there is files in DCIM-EOSMISC that have that written data but on .dat Files.
So is there any solution to get my videos back or fix the corrupted videos

64ee743e82cf449e9f6eb3cddfab26c1_G0227954.gif

WhatsApp Image 2021-03-16 at 3.48.38 PM.jpegWhatsApp Image 2021-03-16 at 12.07.03 PM.jpegWhatsApp Image 2021-03-16 at 12.06.52 PM.jpeg

1 ACCEPTED SOLUTION

I just solved the problem with 2 softwares,

 

for the first .MOV corrupted file i used wondershare repairit software to repair the data,

and for the others i triesd to use repair software but they dont work on .dat files so i used HJ-Split software in this way

1- I renamed the D92A0814.MOV file to D92A0814.MOV.001

2- I renamed the D92A0814.DAT file to D92A0814.MOV.002

then used the HJ-Split software to join them into one file

 

one of the tow files has directly worked perfect

the other one had to use wondershare repairit to fix it

now the 3 files works normaly thank god for that

View solution in original post

9 REPLIES 9

rs-eos
Whiz

What card did you record to (brand, etc.)? What codec?

 

I just recorded eight 10-second clips on my 5D IV to the Compact Flash card (SanDisk brand) using all eight codecs.  Note, I don't have the C-Log version of the 5D.

 

I only see the .MOV files when mounting that card to my Mac via a CF card reader.  One file per clip.

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

I used Sandisk Extreme Pro SD Card 128GB 170mb/s, and i was recording 1080 25 P All-I videos.

what suppose to be normal to find video files in its folder, but there was a problem that cause it to be this way

That should have worked.  Note that the 170 MB/s rating is practically useless.  One needs to pay attention only at the sustained write speed for the card.  Your particular card can handle 30 MB/s (V30) which is 240 Mb/s.  While I cannot record in 25P, my test clip in 23.96P had a bit-rate of 92 Mb/s which is far below 240.

 

As mentioned above though, I was recording to the compact flash card and not SD since I wanted to test all codecs.  The 4K clips required working with the CF card.

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

i have 7 5d mkIV cameras on the set with the same setting and the same memory type this is the only one had this problem and when i change the memory it worked well,
but now i am looking to fix the videos that are on the first memory

I guess the proccess of recording files is to cash media in DCIM\EOSMISC folder then collect them to DCIM\100EOS5D Folder and somehow it didnt collect them into one .mov file so i have the cash .dat file in that folder, i am looking to a way to collect those cash files or .DAT files into MOV Video file so it would work

 

I think you meant to say "cache"?  Anyhow, do you recall the camera losing power during your captures?  I'm wondering why it wouldn't flush the cache.  Also, I find it odd that during recording, it wouldn't just stream the data to the final .MOV file.

 

Anyhow, if it's a very trivial cache, it may be identical to that of the final movie.  In this case, make a copy of one of the .DAT files (definitely keep the original as-is).  Then, rename the copy to have a .MOV extension.  Is your computer then able to view the footage?   If not, then the data captured to the .DAT files is potentially in some other format, represents truncated data, or is otherwise corrupt.

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

Thank you Ricky for your replay, I'm sure that the camera didn't lose power while recording and if you noticed that i have three Separated files that i had cut in between in the set, i tried to rename a copy to .mov and didn't work, so is there any way to fix those files by my self or any trusty software can do it

No problem.

 

I honestly don't know if the data is salvagable.  However, out of curiousity, if you have access to a "Hex Editor" or a way to dump out the very start of those .DAT file as hexadecimal values, it may provide a clue as to what that file contains.

 

e.g. In inspecting the first 36 bytes of my captured .MOV files, I see things like 'ftyp' (abbreviation for "file type") along with qt and moov (Apple, where the QuickTime format originated from, often uses four-letter codes in data files, so 'moov' is a clever short form of 'movie').   So the beginning of this file reveals data that it is indeed a QuickTime Movie.    Here's what I saw in the hex editor on my Mac:

 

hex_edit_mov.jpg

 

Later in the file I saw text indicating my camera (Canon EOS 5D IV).

 

Note: Definitely don't open those files in a text editor or word processor as it most likely would crash (too much data).  Hex Editors are typically smart to not try to load in the entire file at once.

--
Ricky

EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L, 600EX-RT (x6), ST-E3-RT
EOS C70, RF 24-70 f/2.8L IS, EF-EOS R 0.71x

I just solved the problem with 2 softwares,

 

for the first .MOV corrupted file i used wondershare repairit software to repair the data,

and for the others i triesd to use repair software but they dont work on .dat files so i used HJ-Split software in this way

1- I renamed the D92A0814.MOV file to D92A0814.MOV.001

2- I renamed the D92A0814.DAT file to D92A0814.MOV.002

then used the HJ-Split software to join them into one file

 

one of the tow files has directly worked perfect

the other one had to use wondershare repairit to fix it

now the 3 files works normaly thank god for that

Announcements