Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannon t5i not reconized by mac

Hi there,
I need help I have a canon t5i and Mac book pro running MacOS Sierra 10.12.3 I have eos software I plug my camera into Mac open soft ware all icon in soft ware like live view shooting which I need are gray and not highlighted tried two wires that I know are working nothing help me please


When you connect your camera and turn it on you get this screen but the icons are grayed out?



John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Is your camera's wifi connection turned off?  It should be off before connecting to any PC.

Noi wifi for T5i. It will accept an Eye-fi card, but having Eye-fi enabled doesn't affect USB connection.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Thanks, John.  Thought it was a wifi model.  


First... make sure you visit the Canon website, click the 'support' link and make sure you have downloaded and installed the latest software for your camera.  Apple made changes to how USB devices are recognized under macOS Sierra so it's possible that if you're using older software you may have issues.


When you mentioned you tried to wires which you know are working... are these USB cables that you use to charge a phone?


Unfortunately there are now phones that come with USB "charging" cables.  In USB some of the internal wires provide power and others are for data.  A true USB cable has everything wired across.  But a charging cable only has the power wired and the data cables aren't wired.  


What the camera really needs is the data connection (and it doesn't actually care about power -- the camera does not use the power from a USB cable to charge or to operate.  It only uses it's internal battery for power.


You do not have to use the actual cable that Canon provided with the camera... but you DO have to make sure that the cable use use is a full USB cable (all pins are connected and it isn't just a "charging" cable).


Connect your camera to your Mac and make sure your camera is powered on.


On the Mac you can click the black Apple icon in the upper left corner of the menu bar (top left corner of your screen) and then select "About this Mac"


That will launch a small window with information about your computer, but you'll see a button labeled "System Report..." --- click that.  This launches the Mac "System Information" utility.


In the left margin of the System Information utility, under the "Hardware" section you'll find a section named "USB" -- click "USB"


On the right side, you should see a list of all devices connected to your Mac via USB.  Scroll this list and look to see if you can see a Canon camera.


Here's an image to provide an example of what you might see (I connected a Canon EOS 60Da and it appears as "Canon Digital Camera")


Screen Shot 2017-02-26 at 10.56.54 AM.png

Also note (very important) that the camera will only appear in the list if the camera was already connected and powered on when you launched the System Information utility.  This is because it only scans for devices when it launches.  If you attach the camera after launching the utility, you'll need to navigate to the main menubar and pick "File" -> "Refresh Information" to get the utility to rescan.


If the device does not show up in this list, then the computer operating system does not see the device (so there's no hope that any software will see the device).


Common reasons to not see a device...


1)  Are you using a USB "Hub"?  Connect the camera directly to the Mac (don't use a hub).


Some hubs are awful and belong in the trash bin.  I've gone through numerous USB hubs and discovered that more than half are flakey and unreliable.  I found a Belkin model which has been rock solid (and unfortunately Belkin doesn't make that model anymore and I'm unsure if other models will be as good).  


USB hubs actually have firmware of their own.  If you are using a hub, physically disconnect the hub from your Mac and if it has it's own power supply, unplug it.  Reconnect power to the hub and reconnect the hub to the Mac.  This effectively "reboots" your hub.  Now reconnect the camera and see if that doesn't resolve the problem.


You *should* be able to use a hub (I use a hub) but this does require having a reliable hub. 


2)  Are you using the correct cable.  I made the comments above about having a true USB cable and not a "charging" cable.  If you do have these "charging" cables around the house, find the cable that actually came with the camera and label it so you know which cable works correctly with the camera.


3)  Are there any signs of damage to the USB cable or to the USB ports either on the camera or the computer?





Tim Campbell
5D III, 5D IV, 60Da

Thank you guys so much for information I'm not sure if the Cabel is a charging Cabel so I will head to a store in morning and get one for data. No I don't use a hub I have the correct version because when I went to cannon site it recognized my os so I'll be going to store for a new USB wire tomorrow wish me luck

It was the wire need a data wire not just a power cord it worked finally