cancel
Showing results for 
Search instead for 
Did you mean: 

7D Video Stops and shutters

ETodd
New Contributor

I've been using a Mark ii 7D for a while now for video, and sometimes after a while the shutter clicks and it stops recording. Attached is a video from an event i was filming last week and you can hear the 7D (not the camera used for this video) clicking rapidly, it does it without being touched, and when being turned on, and when pressing the video record button. I can't seem to find a way to prevent this. We switched cards, batteries and let its sit for a minute but nothing stopped. I didnt check it again until monday and it worked just fine. Does anyone have any ideas?

 

2 REPLIES 2

RobertTheFat
Honored Contributor

@EToddwrote:

I've been using a Mark ii 7D for a while now for video, and sometimes after a while the shutter clicks and it stops recording. Attached is a video from an event i was filming last week and you can hear the 7D (not the camera used for this video) clicking rapidly, it does it without being touched, and when being turned on, and when pressing the video record button. I can't seem to find a way to prevent this. We switched cards, batteries and let its sit for a minute but nothing stopped. I didnt check it again until monday and it worked just fine. Does anyone have any ideas?


If it happens randomly, it suggests that you may need a faster card. If it happens predictably, it could be running out of either minutes or space, either of which would force it to start over (with a new session or a new file, respectively).

Bob
Philadelphia, Pennsylvania USA

But that's the issue, it doesn't seem to help, switching the cards doesn't change it.