Showing results for 
Show  only  | Search instead for 
Did you mean: 

7D Built-In Flash/Hot Shoe Trouble


Hello fellow Canon users!


For quite some time now, I've been unable to use my built-in flash on my 7D. Naturally I went through Google trying to understand what's the trouble. It seems a lot of folks have had issues with the built-in flash not working properly. I've tried it all from setting it in Full Auto to get the flash to pop up, then Manual and Bulb. Nothing. I've pushed the flash button on the side over and over. Nada. No error message, no clicks, and I don't even hear the motor trying to open it. I've even held the flash button down and manually tried prying the flash open which doesn't budge (and I'm not going to Hulk out on it and make matters worse). When I go into Settings and open Flash Control, Built-in Flash Function Setting tells me "This menu cannot be displayed. An accessory is attached to the camera hot shoe." Well there's nothing attached, but my built-in flash seems to think there is and won't pop open for me. I've even asked it nicely if it will let me in, and it said curtly, "Not by the hair on my chinny chin chin!"


Well I see two ways of going about it: 1. Try to solve the problem or 2. Don't bother with it because I don't really use the built-in flash anyway. I prefer option 1 because I would like to try to figure out exactly what the problem is so I can fix it. Plus I'm not really in the way of being able to throw down some Benjamins, so if I can take care of it with my own two hands, I'd like that.


I purchased my 7D back in 2010, so she's already 7 years out of the box. I've done a lot of photography outside and around animals, so I assumed there was a lot of dust, dirt, and even salt deposits stuck under the metal pieces of the hot shoe. Watching videos on YouTube, I got some ideas to try. First, I cleaned under the prongs with a piece of paper to make sure nothing was preventing them from moving down and back up again. Something did pop out, and I thought for sure that was the issue. Nothing happened. Second, I removed the first metal plate to make sure the two prongs were properly aligned and the four screws underneath securing the other metal piece were tightly in place. They were. Lastly, I removed the four screws and took that plate off to see if anything was out of place. The tiny "button" on the right side doesn't seem to press down, so I'm wondering if this is the culpret of my dilema. Maybe some trace amounts of debris have caused the button to stick in place (I'm assuming this is a button and it is stuck causing my camera to believe that something is sitting in the hot shoe).


Alright I'm sure I've gabbed enough. Any help would be very appreciated. Again, just trying to save money and if I can't fix it, then I'm okay as long as my external flash works with the hot shoe.


Thank you!



P.S. I'm brand new to the forums, so I apologize if I've posted too large an image.







The little button as you call it is definitely the problem, normally this is not actually a button but a small actuator made of plastic that pushes the contacts below. If you grip this piece with a pair of tweezers then it should just lift out.

Looking at the metal part of your hot shoe it looks stained around the hole where the actuator fits so it is possible that you have had some moisture there at some time, moisture will hold dust which has probably jammed the actuator in the down position

Thanks for your reply!


I tried to pull it up with tweezers but got no where. I'm unable to get a good grip on it and I want to be sure I don't damage the plastic.


There are trace areas of rust for sure. I can likely get it cleaned off the metal parts, but I'm not sure if I can get the actuator cleaned. Smiley Sad


The pictures were really helpful.  I see a lot of what appears to be rust -- except I think the screws and plate are stainless so maybe that's something other than rust.  (e.g. perhaps something was spilled on your camera).


The "button" (micro-switch) is pressed by the leaf spring when you insert a flash into the hot-shoe.  It tells the camera that there's something in the hot shoe and that's how the camera knows to not pop-up your built-in flash.  


You'll need to clean up the orange/rust colored residue.  I'd suggest using a few drops of alcohol (denatured alcohol) on a cotton swab -- that way it evaporates and doesn't leave anything behind.   Make sureyou can press & release the micro-switch and that it springs back up easily.  


Do not use oil to lubricate it -- that'll just attract dust and it'll get gunky and sticky again. 


Tim Campbell
5D III, 5D IV, 60Da

Thanks for your reply!


I believe it is rust. I've photographed marine animals before, so I'm pretty sure some amount of saltwater seeped in under my external flash. I hope I can get those spots cleaned up before I piece it all back together. If I use denatured alcohol around the micro-switch (careful to not use a saturated cotton swab), do you think it will pop back up on its own?

If you believe it may have been seawater then it probably has some salt deposit stopping it from moving, as this salt is alkaline then a tiny drop of vinegar would dissolve it. I don't think denatured alcohol will work, if I was going to try anything like that then isopropyl would be better. Denatured alcohol takes a long time to evaporate, isopropyl is much quicker.

Thank you! I'll give that a try.

Well I tried what I could to get the micro-switch to move, but it's not budging. I've decided to leave it alone and just hope that my external flash always works.


Now I have a new dilema. I'm trying to put the four tiny screws back in their slots to hold the metal plate in place, but they won't tighten. They keep spinning. Were they originally held in place with an adhesive? Could I have stripped the screws simply by removing them? I'm really surprised all four are refusing to tighten, especially since I've watched several videos where people are tightening these screws back into place after they become loose.



I managed to actually get one thing fixed! Apparently there is a plate underneath that dropped too low when I removed all four screws. I turned the camera upsidedown and used a paper clip to realign the holes. A bit tricky working with the camera above my head, but after a few attempts, I was able to get the screws back into place and tight.


Just thought I would put this here in case anyone else runs into the same trouble.


Thank you. as a wildlife photographer sometimes I forget how dirty my camera can get and I had a bunch of Gunk stuck in there just reading it cured the problem solve the problem and yes I clean my camera. Works beautifully now and I'm using the Canon ti7

Thank you. as a wildlife photographer sometimes I forget how dirty my camera can get. I had a bunch of Gunk stuck in there. Read your solution to solve the problem.. flash fires now!! Yes I cleaned my camera. I'm using the Canon ti7