Showing results for 
Show  only  | Search instead for 
Did you mean: 

70D Messes Up Wifi Connection


Hi all,


So I've read through a bunch of 70D wifi issues and disconnect issues, etc. This isn't that and as far as I've researched I haven't found anythign on this. 


I successfully had tethered my 70D via wifi to my computer using the EOS Utility. Awesome. Got great shots, quickly adjusted aperature, etc. 


I attempted to repeat this process the following day unfortunately I was unable to locate the camera on my computer using the WTF Pairing. Then, my wifi signal dropped on all devices in my home. I was unable to get onto my wifi for four days. I called my wifi provider, obviously, it's a wifi issue. We did some troubleshooting, they reset something on their end, and fixed it. 


Tonight, I went to tether my camera to my computer, and the same thing happened to the wifi, it went down on all devices. I shut the camera off and re-did some of the troubleshooting steps via the service provider, and boom the internet was back. 


I attempted to re-tether the camera again to my computer, and again my wifi disconnected everything on it. It appears as though when I attempt to use my camera over wifi it does something to my connection and renders it completely null. It takes an hour or more to get back my connection every time. 


Has anyone exerperienced this before? I'm in the process of trying to do product shots that are due soon and I'm having a terrible time with this. 


Lastly, yes connecting my camera to my phone and ipad work via the canon app. But, my wifi for the entire house is down during this process. Unfortunately I don't get the same level of detail on the camera/ipad as I do my computer and am wanting to solve this camera vs. internet issue.


Thank you for your questions, comments, solutions, etc. 


Hope to hear from someone smarter than me. 






Check that the IP address setting on the camera is set to AUTO.  It sounds like the camera may be causing an IP address conflict on your network which may occur if your camera has a static (or manual) IP address.

When I connect to my 70D, my error is:  'Connected, no Internet'.  


When I connect to my 70D, my error is:  'Connected, no Internet'.  

If it's your computer that's doing the connecting, that doesn't sound like an error. The camera is acting as a WiFi access point (because the computer prefers to be a client), but it has no routing capability to the outside world, hence no Internet access.


If you want the camera to connect to the Internet, you'll probably have to configure it as a client (if the 70D is even capable of that) and find an access point with an Internet connection. Some smart phones can serve as access points, and most modern cable modems incorporate an access point.

Philadelphia, Pennsylvania USA


I think that your WiFi DHCP IP is the same that you obtain from your provider, if they gives you IP - and your WIFI DHCP is set to same network "192.168.0.XX" this will cause errors and NO internet connection)


Welcome universua,

This is a 5 yr old thread.  Probably solved or forgotten.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It


There is a very strange moment with the connection. The camera is silent about errors (on the router I see that the device is connected), but EOS utilities do not see the device. And sometimes the program sees the device. The logic of behavior is not entirely clear. Of course, the address is issued automatically.