Showing results for 
Show  only  | Search instead for 
Did you mean: 

70D 4.5 yrs old. Play button suddenly stopped working and cannot record Vdo using start/stop button


I have a 4.5 years old 70D. It worked great till couple of months back. TOday I opened it up after a while and suddenly few things appear to be wrong.

  1. Play button doesn't work. i.e I cannot see my pictures shot in the card that used to work till now. I even reformatted the card on the camera itself.
  2. I tried to do video recording and it won't work either.

However the pictures I take work fine.

So I looked around various forums. Do I have to change the motherboard?

Thanks in adavnce.

Paresh Motiwala




There are a few troubleshooting steps I'd like to help resolve this issue. We'll reset the camera, which should restore it to a default state. These steps should clear out the memory and thereby any errors which may be present.

- Anything attached or installed in the camera — memory cards, the lens, the battery, battery grips should all be removed.

- Once the lens is off let's check it using the steps below.

a) Clean the lens contacts* to restore connection with the body.

d) Try using a different memory card. All memory cards should be properly formatted in your camera prior to use.

*Warning - Do not clean lens contacts on either a Canon lens or the camera body with an eraser! It's easy to rub off the gold plating on these contacts and end up with data communication problems! Our strong recommendation is to use a soft, clean, micro fiber cloth. Please do not use anything abrasive.

b) Try using a different Canon EF series lens. It doesn't have to be the same focal length as the one you were using.

c) If you are using a third party lens, we recommend discontinuing its use. There can sometimes be communication error related issues with third-party lenses. Ensuring that you're using a Canon lens eliminates that as a potential factor in the error.

If the issues seem to persist the next step would be to send the equipment to Canon for service.


you may fill out an online repair request form at the following link to setup your repair using our online service.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


If your buttons are not working it is more likely that it need a new button assembly, this usually means replacing the whole back of the camera. Very unlikely to be a main board fault.