cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5d mark iii& canon flashes

trocks69
Apprentice

here is my issue. i have searched here and online and can not seem to find a solution.

 

when i put my external canon flash on the hotshoe and turn it on. the menu completely disapers and is not accesable. as long as the flash is on the camera and on.  i have tried my two different 600ex rt and my 430ex rt.  all three of them cause the same issue.  

 

has anyone come across this issue.  the camera and flashes worked fine on my last trip a few months ago. the firmware was updated over a year ago on the camera. i can not seem to find the problem here. any help

3 REPLIES 3

diverhank
Authority

Usually this means the camera does not recognize the flash as a proper flash unit.  And that usually means the connections were not properly made - Make sure you clean the pins on the camera hot shoe as well as on the flash and make sure the flash is properly locked.

 

Since you have the same problem with both flashes, that indicates to me the problem is on the camera side...clean the connections well and hope for the best that the problem is not internal in the camera.  

================================================
Diverhank's photos on Flickr

thanks for the reply. i took the shoe apart. at least the outer part and cleaned it. there was some not corrosion but dirty stuff there. it still did not fix the problem. i think something was not put back right when they fixed my memory card slot. since one of the pins was damaged on the inside. before that work was done the flash worked spotlessly.

 

if you can think of any other possible fixes please let me know. i am in colombia right now and would like to be able to use my flash.

now i can stil fire the flash with the camera. i just have to press the shutter button.. but i am also getting a random preflash going off with out touching anything.

 

the screen still does not work. means once the flash is mounted and turned on. i can not use the lcd for anything, live view, changing my settings, view photos, or setting the flash settings. 

 

i actually have to turn the flash off then turn the camera off and back on before i can access all my menus and settings. 

 

really frustrating since i wanted to do some light painting while i was here.

Avatar
click here to view the press release
Announcements