Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mark III Not Recognising CF Card in Slot 1.


I recently inserted a CF card into slot 1, but the camera cannot see it or format it.


I've tried two known, good, error free CF cards, but the camera just tells me they cannot be accessed and to change them or format them in camera.


I've checked for bent pins in the slot, but they seem ok from what I can see.  I contacted Canon Support who told me to revert all camera settings to factory default, which I did, but it failed to solve the issue.  Failing that they advised to have the camera checked at a Canon Service Centre.  The problem is I'm currently living and working in a country that doesn't have a service centre.  I can't afford the downtime involved in sending it to another country to be repaired, so I wondered if any other Mark III users had come across a similar issue and solved it without the need of a service centre?


The SD cards still work, so all is not lost, but I'd like the option to use the CF cards, particularly for high speed shooting, which they seem to handle better than SD cards.


Any tips, suggestions, ideas welcomed.


Mant Thanks




My 5D3 stop reading my CFs. My computer sees them just fine. I googled and ended up here. After seeing no bent pins, I decide what about a firmware update. I updated from 1.3.3 to the latest of 1.3.6 (2019) and presto! My 5D3 sees all the CFs I pop into it just fine.  

Anyone who's looking for an answer, try a firmware update. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th