Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D Mark III Not Recognising CF Card in Slot 1.


I recently inserted a CF card into slot 1, but the camera cannot see it or format it.


I've tried two known, good, error free CF cards, but the camera just tells me they cannot be accessed and to change them or format them in camera.


I've checked for bent pins in the slot, but they seem ok from what I can see.  I contacted Canon Support who told me to revert all camera settings to factory default, which I did, but it failed to solve the issue.  Failing that they advised to have the camera checked at a Canon Service Centre.  The problem is I'm currently living and working in a country that doesn't have a service centre.  I can't afford the downtime involved in sending it to another country to be repaired, so I wondered if any other Mark III users had come across a similar issue and solved it without the need of a service centre?


The SD cards still work, so all is not lost, but I'd like the option to use the CF cards, particularly for high speed shooting, which they seem to handle better than SD cards.


Any tips, suggestions, ideas welcomed.


Mant Thanks




I had a similar problem in that the 5d mkiii did not see one of my cf cards.  I erased it with the computer and then reinserted the card into the camera.  It recognized it then, but just be safe, I formated it several times using the camera menu.  It seems to work now..  Try erasing it on the computer.

Unfortunately, no luck with this.  Many thanks for the suggestion though, barrisster.

If you remove the CF card and close the card door the camera will default to the SD card and will not read the CF card. You have to go into the menu and select the CF card as the one to read. I have never tried it but you might remove the SD card and insert the CF card without the SD to see if it will read the card then.

Thanks JoeN.  I've tried with just the CF card installed, but as sson as I power up the camera I get the message that the card in slot 1 is not accessible. Replace or format in camera.  I suspect this is an issue that only a Canon Service Centre can resolve.


Poor show for a supposed high end camera..!


Thanks Again.

I just bought the Mark IV and I am having the exact same problem.

I just purchased Mark IV and barely used it for one trip; took out Lexar CF card to transfer pictures to my computer. Now I am getting same problem, the CF card is not accessible. Camera doesn't even format the CF card. Any suggesstion where to seek help? Thanks.

Just want to say thanks to JoeN. My sd slot was not reading at all, said there was no card in the camera. After trying several different cards with the same result, I found your suggestion. I removed the CF card, turned on the camera with only the sd and HOORAY. Many thanks.

The only thing I can suggest is that you either have a bad CF card or one of the pins is bent.  Change cards.  if that does not work look to see if all of the pins are straight.

Tried several cards.  Pins not bent.  It turned out to be a problem inside the camera.  


Thanks for your response though, Barrisster.  Much appreciated.