cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

5D MK IV service question/opinion

cityjack
Contributor

Afternoon all,

First time here and just looking for some opinions maybe a shoulder to cry on.
I just bought my wife her dream camera a few weeks back. Basically, while in the living room, she just took it in and out of the camera bag I bought her and snapped some pics inside the house and basically just read the manual.
While on vacation down to Georgia last week and as mentioned after only using it briefly in the house, one night while downloading some pics in the hotel, she noticed some dark/black specs (3 of them) through the viewfinder. The camera as I said is brand new and the lens had never been off. None of the three specs could be seen on any photo taken after downloaded to her pc. I then figured since the spots could not be seen on the photos, the sensor was clean. I could not find a camera cleaning kit anywhere while on vacation, so I bought one of those little "booger suckers" from the infant section at Target to get me by.
First I took the lens off, cleaned the rear with the "Target tool" and visually inspected front and back. Reassembled, and specks were still there. I took the lens back off and while holding the body down opening towards the floor, tried the air tool again. Reassembled, and still, the specs you could see clearly in the same exact spots through the viewfinder. I also used air at the eyecup on the back of the camera, still no results.
I called Canon on a Saturday night and made plans to send it back to Newport News VA for service. I paid 67 dollars for their "Sensor cleaning maintenance" option. Clean mirror, verify firmware, clean body, clean external LCD surface, clean external viewfinder, clean focus screen, and clean image sensor.
I paid the 67 bucks for maintenance, 95 bucks for shipping insurance, and another 15 bucks for shipping.
I sent the camera, a copy of the original receipt, and a decent typed letter of exactly what I'm saying here to Canon. They told me on the phone if the could not get the specks to disappear with the 67 dollar cleaning maintenance option, they may have to disassemble the camera further to get to the prism and/or the inside of the viewfinder. If this was the case, this would be covered under warranty. I said fantastic and thanked the man for his help.
I received an email from Canon once they received my camera and it described the service process and how they'd keep me informed during the complete process up to the point of shipping. They even included a little youtube video of some Canon guy telling me all the nice things they were going to do for my camera and how it goes from their expert qualified technicians then over to their quality dept. for reinspection of the work completed.
I received the camera back just this past Friday. The camera still has three specks in the veiw-finder, although, now they are in different spots. Yes, I drew pictures for my reference. Not only this, there is now a slight off color circular smudge smack in the middle of the black lined framed viewfinder.
How does this get past not one service team but a quality dept. as well. I am more times than not a patient person and I know stuff gets missed, but two separate teams for something so obvious. Especially with me laying out exactly what I see and discussing with Canon before I even send the camera.
I know some of you are probably saying, "Its only a few specs. It doesn't affect your photos". I paid nearly 4K for this camera/lens combo. I want perfect. I do not think thats unreasonable to ask. Especially since I have never taken the camera apart and its basically 3 weeks old.
I plan on calling Canon first thing tomorrow morning to get their remedy.
I'm curious to know your guys' thoughts please. I apologize for the novel but wanted you all to have all info.

Have a good night.

Sid

33 REPLIES 33

Evening guys,

 

Well, I just recieved my camera back from Canon, Newport News, after they cleaned out all the black specks in the view finder, cleaned the entire mirror box, and replaced my focus screen to remedy the blurr or smudge I was seeing in the middle of the view finder.

 

The view finder is now perfect EXCEPT for the slight discoloration/smudge or ghostly small blur that is still in the middle of the viewfinder.  You can only see it when you look at a clear blue sky.  Looking at clouds or anything else, even white paper, its not seen.

 

I took the lens (24 - 105 IS L) off the camera, cleaned with a ZEISS lens towelette front and back, reassembled, and still the ghostly discoloration is still there.  I began to think maybe its normal.  When you move the camera around while looking at the sky, the mark does not move.  Its always in the exact same spot in the viewfinder.

 

I thought surely if it was in the camera body, Canon would have caught it with either of the return trips back to them.  Thats what made me think maybe its something with the lens.  So I researched today, Flare, ghosting, abberations, and other lens issues.  I do not think what I'm seeing is any of these things.  I need a more experienced eye.

 

I called the store where I bought it and told him what I was seeing and what I thought and how its beenback to canon twice in the last month.  He told me to remove the lens and look through the camera again while looking at the sky.  BAM!  The spot/discoloration/smudge was gone.  I put the lens back on to double check.  The spot returns.  Take the lens back off for the 2nd time, the spot disappears.  Some thing is going on with the lens or the lens is making the camera show a spot.

 

Any idea what this could be?  This is the only lens I own so I cannot try another.  Although I DO have a 50mm Canon lens off my 20D.  Not sure if I could try that.

 

I am at a loss.  Oh, I only sent the camera body to Canon, so they've never seen this lens yet.

 

Any help would be greatly appreciated.

 

Sid

The 20D was an EF lens camera, so the 50mm lens you have should fit the 5D you have. Just double check that it has a red dot for alignment.

 

What is the pedigree of the 24-105 lens? There is a thing called lens fungus that can develop inside the lens if it is stored in humid conditions.

 

Fungus.jpg

 

Look through the lens "at an angle". In other words, have light shining through the lens but don't point it directly at the light source. Do you see anything in the lens?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Evening sir,

 

The lens came with the 5D MkIV.  Its brand new.  2 months old.  One of those months its been at Canon.  The camera has been out of its Lowe Pro bag a few times on two different wilderness picture taking trips.  Lens and camera are brand new.

 

I do not think its fungus.  But I'll look and try what you are suggesting.

 

Thank you for your reply.

 

Sid

I'd like to try the 20D 50mm lens.  Yes, the 20D has the red dot.  Would there be a problem turning my 5D's power on once the 20D lens is attached?

 

Thanks again

 

Sid

No problem turning the camera on, but it doesn't need to be on to look through the viewfinder.

 

One other p;ossibility is some sort of smudge on the focusing screen. When the lens is off there is very diffues unfocused light on the screen.

 

When the lens is on and focused you have precise parallel light beams hitting the focusing screen, and if there is something on the screen it will be apparent.

 

So: 1. the 50mm test will determine if it is a lens issue. 2. if you still see it with the 50mm lens defocus the lens and see what happens. 

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Canon, on the cameras last trip back to them just replaced my focus screen.  BUT, neither trip back to them did I include the lens.  Only the body as we thought the specks and this smudge that I was seeing were in the body somewhere.

 

I'll try the 50mm lens tomorrow as well as defocusing like you said when I get home from work.

 

Have a good night sir.

 

Sid

Good morning,

Just sneaking in from work. With my 20D 50mm lens, whats the difference to my newer 5D lens? I mean one is a full frame and the older one not. Do the electronic interface pins all match up?
If my newer lens, the 24 - 105 F4 lens is a fixed F4 aperature, when I change Fstop on the camera, the lens remains stuck at F4? Does the camera have an aperature of its own that I am changing? I am confused.

Thanks

Sid

There is no electronic difference between your two lenses.  Only the FL is different.  The key here is in the name.  Both are "EF" lenses. The lens appears to stay on f4 because it stops down at exposure not as you change the aperture.  There is a DOF button that will stop it down as you look through the VF.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

Yowza Mr. Biggs. I got the Focal length part. But you have lost me on how the aperture is working. So my lens being an F4, does that mean my aperture is variable or no? So if I am changing aperture on the camera, what am I changing if the F$ is remaining the same?

I need a book or link to explain this I think. DOF button?

Thanks Mr. Biggs.

Sid

"So my lens being an F4, does that mean my aperture is variable or no?"

 

Your aperture is variable in that it can be changed to effect exposure.  It is not a variable aperture lens like the ef-s 18-55mm kit lens is.

It varies aperture according to FL. Simplistic but basically that is the difference. Both can vary aperture for exposure just your lens doesn't vary it by FL.

 

So if I am changing aperture on the camera, what am I changing if the F$ is remaining the same?

 

You changed a setting.  That setting does not go into effect until you press the shutter button all the way down and take the shot.  It is really no different than changing any setting.  They don't do anything until you take the shot. Right?  Same, same.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the gallery
Announcements