cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

2 x extender autofocus

BryanShaw1
Enthusiast

I have just purchased a used Canon 2 x extender II.

 

When fitted to my 7D, the Q screen automatically changes to MF MANUAL FOCUS.

 

Is the extender faulty?

 

29 REPLIES 29

Waddizzle
Legend
Legend
No, it is not faulty. The 2x extenders do not work with, or allow for autofocus, with any and all combinations of cameras and lenses.
--------------------------------------------------------
"The right mouse button is your friend."

This use to be true, But not anymore!    BTW no flame intended.

@Waddizzle wrote:
No, it is not faulty. The 2x extenders do not work with, or allow for autofocus, with any and all combinations of cameras and lenses.

 


@CaliforniaDream wrote:

This use to be true, But not anymore!


@Waddizzle wrote:
No, it is not faulty. The 2x extenders do not work with, or allow for autofocus, with any and all combinations of cameras and lenses.

 


It still holds true for the OP's EOS 7D DSLR camera.

--------------------------------------------------------
"The right mouse button is your friend."

Absolutly correct

John Hoffman's unofficial samples proves that a native lens can and does produce similar results, perhaps even a bit better, when cropped to tel-con status as the addition of the tel-con on the lens.  So why bother?

EB
EOS 1DX and 1D Mk IV and less lenses then before!

kvbarkley
VIP
VIP

More importantly, which lens do you have?

The lens is the EF 100-400  L IS.

Without the extender the autofocus options in the Q menu are all operational. When the extender is fitted it only shows a green box MF. Pressing the set button twice turns the box blue but still shows MF. (I'm trying to give as much info here as possible)

 

I know that AF is hit and miss with extenders but It's as if it's somehow switched off - there is nothing there at all, whatever the apperture.

"The lens is the EF 100-400  L IS."

 

The 2x tel-con is not compatible with that lens. AF is possible only with a lens that has an f2.8 or faster maximum aperture. Your lens is a f5.6.

EB
EOS 1DX and 1D Mk IV and less lenses then before!

With the 2X extender in place, even a 1DX III will not AF with using the normal AF system with that particular lens.  With your 7D, AF won't work with the 1.4X either because the aperture rises beyond the f5.6 capability of the 7D as soon as you add an extender.  Once your 100-400 is zoomed out to the f5.6 region, it is at the aperture limit of the 7D.

 

Your 7D turns off the AF function when you add the extender because the camera knows that its AF system won't work with that lens/extender combination.

 

I have never used live view with a 7D so I don't know what AF capabilities it has in live view.  It MIGHT work in live view with that combination but it will work very slowly.

 

Rodger

 

EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video
Avatar
click here to view the press release
Announcements