cancel
Showing results for 
Search instead for 
Did you mean: 

2 x extender autofocus

BryanShaw1
Enthusiast

I have just purchased a used Canon 2 x extender II.

 

When fitted to my 7D, the Q screen automatically changes to MF MANUAL FOCUS.

 

Is the extender faulty?

 

29 REPLIES 29

wq9nsc
Authority

The 7D AF system won't work if the combined lens plus 2X aperture is above f5.6.  So unless you are using a f2.8 or faster lens, the 2X will put your 7D out of AF range.  A lens with a maximum aperture of f4 combined with a 1.4X will autofocus with your 7D because the one stop loss from the 1.4X results in a f5.6 combo.  The same f4 plus 2X results in a 2 stop loss of aperture putting the 7D out of its AF capable range.

 

Even with the sharpest primes I own (EF 200 f2, EF 300 and 400 f2.8), results with the 2X converter are most underwhelming.  With the sharp primes, the image looks OK until you compare and see how much IQ degradation occurs compared to the bare lens.  With lesser glass, the results will be even less impressive.

 

The 1.4X does work quite well with many lenses and as long as the bare lens is f4 or faster, it will AF with your 7D.

 

The 1 series will AF with aperture combinations as slow as f8 but even with my 1DX III the AF is noticeably slower and less sure with this combination (i.e. using an EF 800 f5.6 with the 1.4X which results in f8 combined and it will AF but nothing like the lightning quick results with the bare lens).

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

jrhoffman75
Legend
To be precise, the Canon 2X extender is compatible with the 100-400 zoom, but autofocus will not work.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

jrhoffman75
Legend

I had to hang around the house waiting for a service tech, so I decided to run a little test.

 

I set up my 1D X Mark III on a tripod and mounted a test image on the garage door.

 

With the EF100-400 f/4-5.6L II mounted with the 2X VIII telextender I framed the shot, trying to pretty much fill the frame.

 

Then I mounted the 1.4x and finally no extender (1X).

 

In Canon DPP I turned off all sharpening and performed the Digital Lens Optimizer process.

 

Once that completed I switched to the Fine Detail Picture Style.

 

Once completed I cropped the 1.4X and 1X images to match the 2X as close as I could. Then I exported them as 16bit TIFF files. File sizes were 114MB, 54MB and 27MB (2X, 1.4X and 1X).

 

Then I did a Windows screen capture which produced JPEGs.

 

2x.jpg

2X

 

14x.jpg

1.4X

 

1x.jpg

1X

 

I'm curious what you folks think. From my observation and this limited test my thoughts are 1. the 2X image doesn't seem bad and 2. if one doesn't have a telextender cropping the basic lens, even with just a 20MP body, gives pretty good results.

 

For reference, here is the full 1X image and a 100 percent zoom.

 

100 percent.jpg

 

full image.jpg

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

lesstuna
Apprentice

So I have also now come across this problem with the 2X Converter. I have Canon EOS 6D Mark II, Canon EF 100-400mm f/4.5-5.6 L IS II USM Lens, and have both the Extender EF 1.4X III and the Extender EF 2X III. I have had no problems at all with the AF using any of the above combinations up until today.

I was shooting with just the 100-400 lens, and wanted closer so I put on the 2X Extender, for the first time ever, the auto focus will not work, it has been working fine since January when I bought the extender, and now no matter what I try, it stays in manual focus.

Anyone have any ideas? I think maybe I put the Extender on the camera by accident without the lens attached, and then before doing anything, fixed that, and attached the extender to the lens and then to the camera. The AF has not worked since.

Any solutions? Maybe reset the camera to factory default maybe? The 1.4 Extender works fine, the lens alone works fine, as does my 24-105 lens. Just the 2X III will no longer AF

 Are you sure it ever focused? The 6D Mark II has an f/8 aperture limit for AF, same as my 1D X Mark III, which does not AF with the 2X TC. The 100-400 f/4.5-5.6 would have an f/9 equivalent at 100mm with the 2X TC.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

It has worked perfectly since January, autofocus was not an issue until today.

Not sure what to say about all of that, but the auto focus has been working with the 2X III for 3 months. Oddly enough, I just put the 2X III back on the 100-400 and the auto focus is working again. No question it is working, I just put the camera completely out of focus with the manual ring, and a couple of 1/2 presses of the shutter and bang, focused. I did understand when I bought the 2X III that it would "slow down" the auto focus due to losing the 2 stops, so it would not be good for panning or following a moving target, but it does work for distant still targets. Anyway, it is working again and I have no explanation why it stopped or started working again.

What focal length is your lens at when it focuses with the 2X?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I do not see any way to attach an image here, but it works within the entire range of the 100-400 so 200-800. I have many sharp images at 800 mm equivalent using the auto focus, the CN Tower here in Toronto is 5 miles away, and lots of lunar shots at night, etc. Could it be because of the 2X III newer version or software updates or something? All of this stuff is relatively new, the 6D and 100-400 was last June so 9 months old, and I got the 2XIII in January so 2 1/2 months of using it with the 100-400. All firmware updates were done on everything I have.

The last image I took of the tower on 2022-03-20 the camera details in the properties is f/11, 1/80 sec, ISO-200, 800 mm, and that image is very sharp for 5 miles away.

BryanShaw1
Enthusiast

As the originator of this thread, I gave up with the 7D and bought an R with which the 2x AF works a treat!

I'm really impressed with this camera which was the only mirrorless I could afford. I'd love to try the R5 to see how much better it performs and would be interested to hear if anyone out there has made this comparison.

Announcements

08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x