cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

128GB SD Card -- NO DISK IN CAMERA -- Rebel T6

IVRtechCMO
Contributor

I have a Rebel T6 kit, just received from Amazon, purchased along with a 128GB Ultra SanDisk SDXC 10 card.

 

When I put the card in the camera, the display says, "no card in camera." Everything I've read says the camera works with 128GB cards.

 

However, a 16GB SDXC 10 card works just fine in the T6. And the 128 card works fine in Canon PowerShot G16, but not the T6.

 

 

--- AND --- 

 

This is the second T6 camera, after we returned the first one with the same problem. Was on phone support for that one, and the advice was to return the camera.

 

 

What's going on?

12 REPLIES 12

TCampbell
Elite
Elite

... unless there's an error in the camera specs.  I'm looking at the specs online for the T6 and it does claim that it is compatible with "SDXC" cards (the "XC" in SDXC is "eXtended Capacity).  

 

I have seen issues where cameras or computers can be fussy about the blocksize in the filesystem.  This is one reason (among many) why we always tell people to format the memory card IN THE CAMERA even if the card was already formatted.  This way it gets the format with the blocksize that the camera wants.

 

Have you tried going into the menu for 'format' and make sure you enable the "low level" check-box?

 

Tim Campbell
5D III, 5D IV, 60Da

When I go to "format" in the menu, the error is "NO CARD IN CAMERA."

 

I formatted the card (successfully) in my G16, put it in the T6, and same error.

Thinking this through rationally... the possibilities I can think of are:

 

1. The card slot is damaged or defective.  If this were true, then I should think that no card would work.  But I think you mentioned that smaller cards do work...just not he 128MB card.

 

2.  The card itself is defective.  But if this were true, the card should not work in other cameras.  But I think you verified that it does work in other cameras... just not your camera.

 

3.  The card is not formatted correctly.  This is still a possibility ... even though the camera can’t format it.  I have encountered situations where one computer formats a card and another computer not only cannot recognize the card, but cannot reformat the card.  But if I format it to the correct spec... it works.   Rationally we can’t rule this one out (yet).

 

4.  Canon’s specification page claiming the camera is compatible with SDXC cards is in error (I have encountered consumer products where the manufacturer spec was actually wrong... and working through their support they ultimately discovered their spec really is wrong).  But to rule this out, we need to learn that NO Canon T6 can use ANY SDXC card.  When you worked with Canon support, were they able to lay their hands on a 128GB SDXC card that worked in their camera?

 

I think you said you’re on your 2nd Canon T6 and still having the problem (unless I mis-read).  If that’s really true... then I’m going with #3.  I have seen memory cards get formatted by computers in such a way that other devices cannot recognize NOR reformat them (even though the other devices that try to use the card are not defective.)

 

Tim Campbell
5D III, 5D IV, 60Da

Not sure it's #3.

 

I formatted the 128GB card in my Canon PowerShot G16, the T6 doesn't recognize it.

 

I formatted the 16GB card in the G16, the T6 recognizes it, and writes photos/video to it with no problem.

 

I formatted the 16GB in the T6 for grins, and it works fine in the G16.

 

Also another oddity, there's no menu option to update the firmware (after saving the update on the 16GB card) in the third set-up menu (as described in the update instructions).

 

 

Canon support only confirmed the 128GB SDXC is supported by the camera.

 

And I'm 99.99% certain I used a 128GB card in an earlier-version EOS Rebel T-series to shoot video 3 years ago.

Maybe... but a G16 is not a T6.  They’d don’t have the same firmware.  When you contacted Canon support... did they actually lay their hands on a T6 body AND a 128GB SDXC card to confirm that it works for them?

 

Tim Campbell
5D III, 5D IV, 60Da

Support did not do that.


@IVRtechCMOwrote:

Support did not do that.


Stick to cards that are 32 GB, or smaller, with that camera body, and all of your card problems will go away.  Just make sure to low level format the card in the camera prior to first use.  Despite appearances, new cards are not preformatted.

--------------------------------------------------------
"The right mouse button is your friend."

-- sigh --

 

EOS Utility software doesn't "see" the camera. (I've used it before)

 

 

Tried both versions 2 and 3 of the utility on my Mac with High Sierra

And 2 different USB cables

 


@IVRtechCMOwrote:

 

 

And I'm 99.99% certain I used a 128GB card in an earlier-version EOS Rebel T-series to shoot video 3 years ago.


You should not expect a card formatted in one model of camera to work in another.  Cards should always be formatted in the camera in which it will be used.  Using microSD cards with adapters is not recommended, either.

--------------------------------------------------------
"The right mouse button is your friend."
Avatar
click here to view the press release
Announcements