cancel
Showing results for 
Search instead for 
Did you mean: 

Sudden focusing issue on RF 24-105mm f/4L IS USM

peter_b
Apprentice

Hello everyone,

I'm new and hope I'm posting this in the correct place 🙂

I took some pictures today with my RF 24-105mm f/4L IS USM lens on an EOS RP. It worked fine, but all of a sudden now, in the rage of 24-50mm or so, the left side of the view field is blurred. I can't focus in that area, and all pictures I take come out blurred (on that side) - see attached image.

What happened? Can this be fixed?

Thank you already!IMG_0703.JPG

7 REPLIES 7

kvbarkley
VIP

Something is decentered on the lens. You will have to send it to Canon.

shadowsports
Elite

Greetings,

Blurry with all attached lenses or just the 24~105?  Were you moving when this image was captured?

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Hard to move on just one side of the image!

ebiggs1
Legend

You need to call Canon. (1 (800) 652-2666)  It does look like something decentered. Did it get dropped or a severe hit?

EB
EOS 1DX and 1D Mk IV and several lenses!

kvbarkley
VIP

peter_b
Apprentice

Thank you very much, everyone, I really appreciate your answers!

I really can't recall it getting hit or bumped against anything...no sign of that, and I think I'd have noticed...but I'm not sure..

I'll call Canon, and might need to send it in, as some of you suggested...

Thank you very much!

Hazel_T
Product Expert
Product Expert

Hello peter_b,

Looking at the photo I agree with other posters that the lens most likely needs to be sent in for service. There are a couple of things to check before sending it in. First it would be good to try cleaning the front and back lens elements with a dry microfiber cloth. Sometimes if there is a smudge on the elements it can cause an issue like this.

If that doesn't resolve the issue the next thing would be to try loading a different memory card in the camera. This looks more related to the lens, but it would still be good to double check just in case the card isn't saving the files correctly.

One last thing would be to attach a different lens on the camera to make sure the same thing happens. In some cases an issue like this can be related to an issue with the sensor, so it would be good to check. If this is happening with all of your lenses we would recommend sending in the camera body. If it is only happening with this one lens we would recommend sending in the lens.

If you need assistance with sending the lens or camera in for repair you can call our support team at 1-800-652-2666 from 9 a.m. to 9 p.m. Eastern time Monday through Friday and 9 a.m. to 7 p.m. Eastern time on Saturday.

Thanks

Hazel

Announcements